Latency when recording internal instruments

I’m experiencing latency when recording an internal VST Instrument to Audio that is worse than it should be and I can’t figure out what’s causing it. Here’s the issue:

  • Open an empty session, no plugins on the Stereo bus or CR, nothing loaded. Set buffer size to 32, disable ASIO guard.
  • Load VST Instrument track with instance of Padshop. Send output to a Group.
  • Load Audio track with input coming from Group.
  • Delay Compensation disabled.
  • Hit record on both VST Instrument and Audio channels and play a few notes.
  • Zooming in there is roughly 15-20ms of delay beween the recorded midi note and the audio.

I have no idea what is accounting for this much delay. I asked some friends who are also on Cubase 13 to try the same setup and they are getting maybe 2-3ms of delay or less. I can replicate this issue even with Built in Audio to rule out my soundcard which is an Apollo x6 but even still, this is an internal VST (not even a third party plugin) record to internal audio so there should be almost no delay at all.

My specs/setup: Mac Studio Ultra M1 with 128GB RAM running Cubase 13.0.4 (running natively, not in Rosetta)
MacOS Ventura 13.6.6 on a clean install with a clean install of Cubase 13.0.4 so all the software is freshly installed. I can replicate the issue whether or not ASIO guard is on or off, whether “Adjust for Record Latency” is toggled or not. It’s not a buffer size issue as it happens on 32. I also tried toggling ASIO Latency Compensation in the Recording> MIDI settings but same issue whether on or off.

Anyone have ideas why i’m seeing this much delay?

Maybe compress and upload your minimalistic test project to make it easier for others to see exactly what’s going on and more easily test with their platform?

I ran into something quite similar and it turned out to be plugins in the control room channels. I had to delete the plugins for it to go away.