Latency....?

Greetings! Finally bought Cubase 8.5.

Thought I record a song I wrote, laid drums ok with EZ Drummer, went great
Then I was going to add guitar, went great playing along, but listening to it the guitar was off by some milliseconds all the way.
Tried different amp plug ins, they were all off by the same amount. Didn’t have this problem in Cubase 6.5, it got to be a setting I missed in Cubase.


Can someone help me?

I run a MAC with OSX 10.11 Duet, played with Positive Grid, Amplitube 4 and Amp Simulator.

Hi,

Is also the dry signal off?

I don’t know the reason, but you can fix it by using the Delay parameter, which is under the Volume an Pan sliders in Track Name tab of Inspector. Set the negative value.

This is the dry signal but now it’s just the FIRST NOTE that is somewhat off.
https://soundcloud.com/user765570843/test1-output-stereo-out-01

I’ve attached a screendump of the device settings.

Tried the same thing in Garageband, worked flawless!

Best regards/
Nick
Skärmavbild 2016-01-05 kl. 10.22.03.png

I had the same problem when I started using Cubase 8 but the cause was a misuse of a plugin.
There are plugins that add significant delay if the checkbox “live” is not set.
In my case it was the Multiband Compressor.
This option unset makes the plugin work better in edition and render but must be set for recording.

Regards,
Lluís

Where is this checkbox located?

MultibandCompressor.JPG
Check for inserts in your tracks.
Edit inserts (the little e button)
Look for LIVE checkbox.

This plug-ins Delay is solved automatically in Cubase. All tracks are shifted virtually to be sample-accurate and in sync with other tracks.

Problem solved! Thanks guys!