Latest eLcc won't run on W7 x64

Looks like it needs SP1 and due to the way my HD was originally configured I cant install this.

If you can’t run the eLcc you don’t have ANY version of Cubase anymore. Cubase Pro 9 was running perfectly until yesterday now I have nothing! Can’t roll the licence back, nightmare. Also see here;

https://www.steinberg.net/forums/viewtopic.php?f=253&t=140658

I want my old licence/eLcc back!!!

Have you tried the older elicenser for XP/Vista?

https://www.steinberg.net/en/company/technologies/elicenser.html

But even if the elicenser works I’m not sure 9.5 will work without SP1…Surprised that C9 was working tbh.

I tried the older elicenser and it works but can’t understand the new license. Both license and eLCC seem to have completely changed. C9 was working perfectly until yesterday! Now no version of Cubase does!

What do you mean it can’t understand the new license? Is there no license showing at all in elicenser control centre?
Did you run maintenance?

The old eLCC shows my Wavelab Elements license HSO, etc but says “Unknown license” instead of Cubase. The W7 PC is not online, I download software & licenses to this W10 laptop. I’ve always performed maintenance on this machine and transferred the USB licenser without any problems for the last six versions of Cubase. No more it would appear.

it’s possible you have a similar thing going on as this thread…Worth trying the fix in Dirk’s post for offline computers.

https://www.steinberg.net/forums/viewtopic.php?f=226&t=89022#p498759

Wow! what a Star you are! The licenser can now see the license! I’ve now got Cubase 5 and Cubase 6 (Both32bit versions) working! Weirdly, none of the 64bit versions get past initialising, but It looks hopeful now.

A huge Thank You from me!

I had to put my Win 7 64 bit pc on the internet and get updates to get my Cubase Pro 9.5 64 bit to work.
I then took it off the internet and disabled automatic updates in control panel.
I use Jbridge for my 32 bit plug ins.

Thanks for that. I’ll probably give it a go later but I’m not optimistic, the boot sector is on another partition and I don’t think the updater will like that. I use jbridge too, I just have C5 and 6.5 left as 32 bit versions as there are some VSTs that wont bridge. Hardly ever use them now but they’re there anyway. I wish I could get C9 to run! I’m not keen, but may have to bite the bullet and call the current system SSD a 32 bit only drive and start again with W10 on a new drive. Nightmare! wish I had a time machine!!!