Latest update broke all my songs. Thanks

I had some troubles in the beginning because i was used to cubase, but finally gor the hang of it and got it workin.
Today i did the update and guess what, nothing works anymore.
It keeps forgetting my midi outputs, sending wrong messages to my keyboards, all the saved songs are missing the audio files (it loads a blanc file and when i import the same audio file it gets imported twice)
Thank god i still have cubase as backup for my gig tomorrow, that works.

This is saved locally, and in the project. When does it “forget”, what do you expect and what happens (not)?

It only sends messages which have been programmed. We’d like to help, but need more specific details - what is sent wrong, when, with Layers or Tracks or…?

You probably have moved the project or its assets, or renamed folders, or “Save As” to a different location or the like. It doesn’t just loose connections to media files, there must have been changes. Is the project file in the same folder where it was when you imported or recorded the audio files? If not, try to move it there and open, does it find the files then?

If all of this doesn’t help, you may send a .vlprj file (nothing else needed) and we can tell you where it expects the audio files and you can check if those are existing there.

That beeing said, a) there is “Save Archive”, which copies assets such as audio files to the new location, and b) we will store the local filenames of assets with upcoming versions, so those are found even if they are nowhere near the project (.vlprj) file. For now, make sure to not move or rename files, VST Live relies on information it has stored in the project.

Hi musicullum

Thank you for your reply

“This is saved locally, and in the project. When does it “forget”, what do you expect and what happens (not)?”
It’s like when i power off my pc, restart it, turn on vst live, open my project and none of the midi outputs are connected. i even have to reassign the midi outputs in the layer, per part, for external synths

“sending wrong messages to my keyboards”
I programmed program change messages to my roland fantom 6 in the layer per part. Before the update it worked, the program change message switches the scene on my roland. Now it only switches 1 sound in the scene. I know the Roland needs msb, lsb and program change, but i stay in the same bank on the roland so i shouldn’t matter that i only send program change. In fact, in cubase it still works.

“all the saved songs are missing the audio files”
Nothing has been moved on my pc.
Actually on my stage laptop i have the same issues.

Oh, an i forgot that all audio clicktracks are not in place anymore

When you saved the project, ports were ok then? That’s weird.

You define this in “Devices/Connections”. If all of your Layers show “MIDI OUT 1”, and you want all of them to go to “Fantom 6” (or whatever your hardware ports name), set “MIDI OUT 1” to “Fantom 6”, and all Layers with “MIDI OUT 1” should send to the Fantom, no? Pls understand the connections settings. No need to re-program all Layers.

You know the visual names of the ports in “Connections” matter: those it finds in the project and searches for the associated hardware. You don’t change those beforehand, do you? Even then it should override those. Maybe there is a misunderstanding:
Layer->Instrument->MIDI OUT 1
connections: MIDI OUT 1 → Fantom 6 (or whatever your hardware driver/keyboard name)
Save, load, see connections: still the same? If so, what does it show in Layer Instrument, is it MIDI OUT 1?
When you set an Instrument in a Layer, and you select a hardware output instead of e.g. “MIDI OUT 1”, it will create a port (connection) with the mame you give it. That’s the visual name. If you provide no name, it will take the hardware port name. So “Fantom 6” would be routed to “Fantom 6” (don’t know what the fantom name is). When you save all this and load it again, connections should show “Fantom 6” → “Fantom 6”.
Does any of this make sense to you? If it still doesn’t work, can you send a .vlprj file that reveals the problem? Thanks.

We found a bug which attempts to translate older Layer settings to newer ones. Pls check “Layer/Layer Controller Map” and there cc#32, it might be set to cc#0 whic is most probably not what you wanted. Will be fixed with the next update, sorry. Does it work then?

Could you send a .vlprj file? Just that, nothing else needed. Thanks.

I just deleted everything because it was sooooo frutrating (almost threw my lt out of the window hahaha)
I did a fresh install and starting from scratch. I hope this time it will be ok. If not i’ll let you know

How do i send you the file? The problem is still there.
Just imported a mediaproject from cubase and saved it as project, then closed VST live.
Opend VST live again, loaded the project, and all audio and midi disappeared.
Can’t check if the routing still works because the midi data is gone.

Also the zoom isn’t working properly. I don’t see the end of the song, even when scrolled way to the right.

Did you use version 1.1.42 already?
You can send a vlprj file via PM, or to m.spork(at)

Hi @musicullum ,

Could it be possible to display somewhere the links of the audio files of all the events.
For all people who have problem with blank events (and so probably audio files in bad folder), we could easily reconnect the correct folder to the events.

I’ll send the file tonight. Running latest update

Something like the pool in cubase would be great indeed

Yes, we’ll add that.