Lato Bold (re)moved when installing Dorico 2 after 3

Something I noticed while tracking down a video issue:
If one (re)installs Dorico 2 after installing Dorico 3, the Lato Bold font seems to be (re)moved.
Opening Dorico 3 projects always prompts the missing fonts dialog.
(Or something else to do with the changes in font handling causes the dialog, I’m not sure.)

Reinstalling Dorico 3 fixes this, so this is a very minor problem (for people with fast/unlimited downloads :wink: ).
Just wanted to make a thread so the team is aware.

(Yes, I did restart between installations)

I don’t know how reinstalling Dorico 2 could possibly interfere with the Lato font, since that font gets installed in the system-level Fonts folder and the Dorico 2 fonts installer doesn’t even “know” about the existence of the Lato family.

Just my experience, maybe something else inbetween reinstalling D3 caused it, and it is pure coincidence.
It drew my attention, as it only happened after reinstalling D2, and went away after reinstalling D3.

But again, not a big issue!

I have the exact same issue, although I’ve only upgraded from Dorico 2 Pro to Dorico 3 Pro. Is there a way to install this font without reinstalling Dorico?
Thanks

In the end I ran into a more frustrating issue (https://www.steinberg.net/forums/viewtopic.php?f=246&t=178443), so I did a reinstall. This font issue has been resolved by the reinstall (but my other issue #178443 unfortunately still remains).

Note that Dorico might not be warning of missing fonts per se, but of cascading styles which are unavailable for that typeface, e.g. Lato Bold Semicondensed Ultra Italic.

Having uninstalled Dorico 2, then installed Dorico 3.1 (and tried a reinstall and reboot after still missing the Lato font), it looks like some of the fonts such as Lato are not being installed (Libre Bodoni was installed). I found the fonts were available in the C:\Windows\Installer$PatchCache$\Managed\38E63638FCC642A4AA8C314651CE14E6\3.1.0 directory, so I selected them all and right clicked on Install. Confirmed they were now in the Windows/Fonts directory, and no messages in Dorico about missing fonts. Not sure why some of the fonts not being installed, possibly some permissions issue?

Thanks for the additional report about this. I’ll ask our testing team to investigate this more thoroughly to make sure we catch any gremlins in this area.

I also get this message. It seems to happen anytime I open an existing file in Dorico 3.1, regardless of whether it was created in the new or old version. I know it’s only been a few weeks, but any updates/fixes? It’s easy enough to ignore the error, but if it could go away, that would be even better. :smiley:

Jeremy

Hello Daniel and colleagues,
I had similar issue when I did new installation of Dorico 3.1 on my Windows laptop, but with the Academico. The font wasn’t installed alongside with
Dorico and I’ve had to manually transfer the font from my Workstation, to the laptop.
So, please, check if the installer installs Academico properly, too! :slight_smile:

Best regards,
Thurisaz

I think I can pretty confidently say it installs correctly, or a rather large number of users would be posting about it…