Launchkey MKIII 61 weird behaviour in Cubase 12PRO

Hi everyone,
I’m encountering a weird behaviour with my new Launchkey MKIII 61 and Cubase 12 pro on a 2021 MacBook Pro M1 max, OS Ventura…

My first experiments were ok and as I’d plugged LK I was ready to work but yesterday I launched a first project and everything was ok but when I opened a second one - at the same time, keeping the first opened - suddendly pads colours disappeared and so all the commands lights even if every function was ok…

After various attempts trying to understand I realized the problems appears to be ‘project related’; in other words: if I load certain projects - even one at a time - everything is ok but if I load others problem reappears…
Missing lights seems to vary from case to case…
I’m asking what could be the reason for this and where I could search in Cubase settings… Obviously I wrote to Novation support too but, being saturday, I guess I’ll have to wait a little…
Novation firmware is up to date.

I’v read many posts in the forum but I didn’t find anything similar until now…

Thanks for advices and hints…


I’ve checked the published script and I saw that upon activation, which is actually happening every time you activate another project, the pads are reset. After this step, they are updating based on some variables being changed.
However, upon a project’s activation, some host values are changed before device’s activation event, as stated in this post:

Not sure, if this could be the root of the problem you describe, but you can take a notice in case Novation gets back to you and asks for more info.

Hi @m.c,
thank you for answering!
I don’t understand anything about scripts and programming them but what you’re saying, if I understand well , is that every time I load a new project in Cubase LK resets, but not in a completely predictable way, right?
I’ll do some more experiment tomorrow and I’ll let you know if can understand something more…

Nope, it just resets its pads to no colour, waiting for events to update them accordingly.

Here’s my suggestion to start with:
Open a project, check if everything works fine, then instead of activating another project, close Cubase and open another one afterwards. If the issue is still there, then yes, it may be project related, though I can’t understand what can possibly cause this. If, however, there’s no issue, then, it has to be something with the script-API sync.

Not sure I do either, so no worries :slight_smile:

HI @m.c,
sorry for my delay…

I did exactly the way you described ant the issue still occurs so it seem to confirm that it’s project related but I cant’ guess why…

Sorry for my ignorance: what’s a “script-API sync.”?

Thank you for answering,

Hi, the API sends all necessary info to our scripts. There are times that inside our script we don’t handle the info when they arrive, as said in an earlier post here.

By the way: they answered me to check MIDI settings in the guide… Not very useful as I had done it yet. I asked for something more specific

Sorry I had missed it. I’ve read it now but it’s a bit too esoteric to me… :slight_smile:

Maybe I’ve found out a workaround for my problem… :crossed_fingers:
When the color problem occurs I open the Midi Remote Manager in the lower window and in the ‘scripts’ tab I disable then re-enable the MK3 script: magically colors reappear in accordance with project tracks!
It worked even with the project that caused the problem first…
I’ll have some more try but it seems to work!
Hope it’s useful, thanx for helping!

Hello, does anybody know why I have this kind of problem in C12 pro, and C13 pro?
And sometimes novation stops my Cubase or shows only a few pads lights? And that soultion showed above I have to use almost all the time I open Cubase.
Thank You for any information.

I’ve got a MKIII 49 and another problem that I encountered that’s computer related is that the USB port in an OLD mac can be underpowered. When I bought a USB 3.0 card, the 49 worked flawlessly.

Just adding this info in case someone is troubleshooting out there.

Hi @Krzysztof_Malek,
and welcome in Cubase forum!
The solution I suggested is the only one I was able to find and I didn’t find any other, so I’m afraid you’ll have to use it for now…

I received this las message from Novation, a few days ago:

Hi Art,
Thanks for sending that over.
We have been unable to replicate the issue you are having here. Just to clarify, is there any similarity in the Cubase projects that are not working when switching between them?
Since this is only occurring when using specific projects in Cubase, then it may be worth reaching out to Steinberg for further support on this.
Let us know what happens and we will be glad to offer any assistance we can.

I haven’t write to Steinberg support yet, as I was too busy, maybe I’ll do next days…


Thank you for this! :pray:t2:

You’re welcome. I’ve noticed that everybody who’s in the selling business is also playing the blame game, Apple included. I think they all know or suspect but don’t want to point their finger at Apple’s aging hardware. Just my opinion.

Last year I was looking at forums and couldn’t figure out why my Launchkey MKIII 49 was working intermittently and most often not at all until I bought the USB 3.0 card (cheap little thing) and realized the problem was with being under-powered. It seems that if there’s not enough juice going to the keyboard, you get the default error message saying: “We have been unable to replicate this issue…” :smiley:

I’m glad I figured this one out for myself and it seems no one else had such a simple answer — “you need more USB power than your old Mac can offer.”

I will now have to go into hiding for having leaked this information. :smiley:

[Also, I seem to have earned my first emoji badge with this post. I’m overwhelmed; I hadn’t even prepared a speech.]

1 Like

Sure. Try to avoid literally any advanced midi controller forum, since they all have the same problem actually :slight_smile:

Thank You for this a piece of information. I did not do anything to have this problmes. But when I have opened C13 for the first time and plugged a novation controller this meesage has occered:
MMCSS priority can not be set!. I was supprised. C12 has never showed me this massage. I was thinking that I have found the problem and also a solution. Look at this topic, please:
I have also installed a program/aplication and I did what I was told to do. And was glad that I have solved the problem. I was starting to use a novation controller instad of nektar midi controller (it is good controller, but I want to use “goodier” one), happy that… uff…, problem was solved. But it has returned. Why?
Because of that problems novation stayed unplagged for many months. I was using a nektar controller instead. I have no time to find another solution. Maybe You or someone will do?
Thank You again for an information. I was glad that I was not the only one who had got this strange problems with novation.
*(sorry for my English)

HI @Krzysztof_Malek,
you’re welcome, sorry for my delay…
Fortunately for me I’m on a Mac so I didn’t encounter this specific issue so far…
Hope everything is ok now!