Legato Flute phrase not working correctly

Hi All, you’ve been great and I’m making a lot of progress with your help!

I’ve got a lot of the kinks worked out with using EW Opus, except for one thing. The following phrase doesn’t play back correctly. Specifically, the two sixteenths just before the fortississimo dynamic and the following notes (16th, 16th, eighth, and dotted half)


Video showing, using EastWest Opus, the problem on the last half of beat 4 of m. 15 going into m. 16.

Video showing, using EastWest Opus, mm. 12-18, highlighting the fact that everything else works for the flute:

Sorry for whoever was trying to edit at the same time as me… I overwrote because I felt like the additional info I just posted was important for anyone to come to a conclusion.


I did map the ‘Leg Slur MAX’ keyswitch to the ‘legato’ playback technique in the expression map. Not sure why but Dorico interpreted the beginning of 17, 18, and 19 as ‘Natural’… Unlike the sixteenths where the problem is.



Anyone? Any help would be appreciated.

What I’ve tried so far:

  1. Tried the very same notes with Orchestral Tools Berlin 1 Solo Flute and it works.
  2. Tried the very same notes with BBCSO Core Flutes a3 and it does not work, it stumbles on the sixteenth notes as the videos demonstrate.
  3. Tried the very same notes with EastWest Opus 3FL KS Master and it does not work, it stumbles on the sixteenth notes as the videos demonstrate.
  4. I changed the pitch of the first sixteenth note AFTER the bar where the four 16th notes in question are and everything sounds good with all players.
  5. But the moment I switch back to the last 16th before the bar being the same pitch as the first 16th after the bar, it fails in BBCSO Core and EastWest Opus, but works in Orchestral Tools Berlin Inspire 1.
  6. I double checked the CC and velocity settings in the Opus manual for EastWest and I’ve got them set correctly in the expression map.

It’s impossible to tell without seeing how you’ve set up your expression maps for each VST.

(FWIW BBCSO Flutes play back without problem here.)

I hear that some repeated tones disappear. You could try to make a bigger gap between two repeated notes. In EW Symphonic Choirs I had to do that sometimes to avoid the disappearing of the repeating note (the second of the 2 equal notes).

How can I do that without affecting what’s notated?

I downloaded the BBCSO expression maps that Paul Walmsley posted on the forum posting, “Expression Maps for Dorico 3.5+” and the sixteenth notes are still not playing back correctly.

I’ve uploaded the map for ‘BBC SO Winds.doricolib’ below:

BBC SO.zip (6.4 KB)

Can you post your file (or a cut down version), so we know we are all working from the same base?

Here you go:

Flute Figuration Testing.dorico (1.4 MB)

So, now you will have everything I have. If you still say it works, then I might have bigger problems on my computer.

Btw, I just opened the exact same .dorico file in Dorico 3.5 Pro and it works with Orchestral Tools Berlin 1 Solo Flute, but not BBCSO. Just to be clear, it doesn’t work in Dorico 4.0 Pro.

For some reason after I save the changes in 3.5 and re-opened it in 4.0, now it’s working, but just for OT Berlin Inspire 1.

Here’s what I get with BBCSO, same file (you can hear the difference on the sixteenth notes at the end):

I have made a picture. Follow the red numbers. Number one you have to do only, if there is no window at the bottom of the window. When you have select number two and number three, you can make the notes a little longer or shorter in sound at number 4, but the note in the staff don’t change. The easiest way is to select first the note you want to change in the staff. That note is now selected also in the bottom screen. This is especially more easy with repeating notes because two repeating notes can look like one long note. But when you select the write note, you can see the note you want to adjust, well.

That worked! So, thank you so much!

I still wonder where the problem lies though. Anyone want to chime in? This is a work around and it does work, but seems like you shouldn’t have to do this to get it to work.

Quick update. It works better with the BBCSO player than the EastWest player. I had to decrease the length of the notes for the EastWest version a little more to get it to work. And like I mentioned previously, no modification was necessary for the SINE player by Orchestral Tools.

However, I’m not going to mark this as the solution, because technically it’s not a fix of whatever is causing the problem in the first place. Maybe Dorico could add a ‘Work Around’ button? I’m guessing if I had a faster CPU and more RAM maybe the player would be able to respond in time for both notes to play back accurately? But I would have thought an i9 10900X CPU with 64GB of RAM and an internal SSD PCIe driver (C) and a normal SSD drive (D) would be enough.

I’m sure it plays back better with BBCSO because their plugin is much less memory/CPU intensive than the EW Opus plugin.

Good to hear that this worked. My experience with this kind of things is, that we have to deal with imperfect tools. After the first update of Dorico 4 things worked better than before that. So there was first a problem with Dorico. But the problem can also be with the vsti (difference between libraries). So, me for myself, as long as I get things done, okay.
But for you things can be different, of course. Good luck!

Some patches insure legato by very slightly overlapping the end of one sound with the start of the next. That can be very beautiful, but with instruments not known for a high velocity attach, repeated notes can sound blended together.

1 Like

I don’t know if it makes a difference, but your EW flute map does not assign a technique to legato notes >medium and < long. You might like to adjust one or t’other. (You can see the gap in the playback techniques lane)

Thanks for the response, but I’m reverting to the Orchestral Tools version which has pretty much always worked for my flute track, but not because of the repeating note issue, but simply because the OT version of flute sounds so much better, nicer vibrato etc. But it was good to know how to resolve issues such as this in the future if I come across it again!

Ok, I’ll look into it. Thanks!

I know this post is a little old and you kind of solved your problem, but I just wanted to add that there seems to be a bit of a problem regarding legato patches from the Hollywood Orchestra Opus library. I’ve seen this behavior with strings also. I managed to make it work by changing the playback to the “Bow Change” patch whenever I had repeated notes in a legato phrase, but unfortunately that solution can’t be applied to woodwinds. I also had a problem where there was no playback of some notes in longer legato passages that didn’t involve any doubles, and I managed to solve that by increasing the number of Max Voices allowed from the instrument’s right panel Inspector window (I must add that this didn’t occur unless I activated all the 4 mic positions available, as that significantly increased the number of voices during playback). Other playback problems with legato patches and with the transitions from them to other articulations can be solved by fiddling with the Release control of the patch, as I find the default 700ms to be too long most often than not. Also I don’t like the -12dB Sustain setting that seems to be the default. I just set it to 0dB, as well as the Attack to the minimum. And generally, the KS patches only seem to work well for Shorts (with 0 attack and the rest of the settings I mentioned before), the other patches I load up on different channels in the same Opus instance and I use the MIDI Channel Change function of the Expression map to change between them. I’m sorry, for the long post, but maybe this can help your future projects and possibly others’ as well.

I know this post of mine is a little old, but didn’t want to open a new one since this is still directly related to what I’m doing. I just purchased BBC SO Pro and the Flutes a 3 legato doesn’t sound at all like legato on a quick note slur (see previous notes above regarding the sixteenth notes I was working with in the videos above, for example at the end of measure 9). When I switch to ‘natural’ aka ‘long’ (BBC terms), it sounds more like legato than the legato instrument! What am I doing wrong? I’d hate to think that EastWest’s flute works better than BBC SO, after all the money I’ve spent on BBC SO Pro (I switched from Orchestral Tools flutes to EastWest’s flute since the previous posts above). I know this is specific to BBC SO Flutes, but you all have been so responsive in the past with such good info, I thought I’d try here first, that is, if anyone has experience specifically with flutes for BBC SO Pro. Btw, I used Spitfire Audio’s newest templates/expression maps specifically for BBC SO Pro.

I don’t want to remove the slurs, because then the performer will assume I want distinct, separate notes where I actually want a smooth slur.

UPDATE: Incidentally, I temporarily slowed the tempo down to q=40, just to make sure I wasn’t “hearing things” and it sounded perfectly legato at that tempo. The funny thing is, when I sped it
back up to q=72, now it sounds great! Not sure if there was some reassessment done by the BBC SO engine? I think the problem is that I wasn’t use to hearing nice, crisp clean attacks on the first notes of each sixteenth note slur (two notes each time).

Note: Not that it matters for this post, but I’m trying to get to the point where I’m just using one orchestral library within a given piece, so I don’t have to worry about differences in mics, reverb, placement etc, not to mention the added complexity of using more than one library in a given template, not that that’s necessarily a bad thing.