Legato Midi command not working

I’ve assigned a key command to Legato (MIDI/Legato) and adjusted the ticks in Preferences (Editing/MIDI/Legato Overlap) but when I select midi notes and trigger the key command, nothing happens. Can anyone else confirm or let me know what setting I’m missing? Works on my Nuendo 7.


It works to me here with Cubase 9, on Mac.

It works on PC too.

Maybe I see your problem: remember, there should be a gap between notes for the Legato function to work.

Yes, Legato in this case is to make Notes longer, when they are short. If you want to shorten Notes and set the Note Off to the Place of Note On of next Note, use MIDI > Functions > Delete Overlaps (poly), please.

Thank you. I’ll try trashing my preferences.

Worked today when I started my computer. Weird. Thanks.