Legato Playback timing

If you look at the timing parameters for the default legato in the Play Options timing page, it shows 105% of duration. This should overlap notes in the play mode view of the actual note duration. But it looks like it is applying 105% to the 85% default note duration, so you still don’t get overlap for legato unless you increase the default normal note duration timing to say 95%.

Is this the intended effect?

This seems to be different from previous version, but I could be wrong about that. But I don’t remember running into this issue before.

I do not believe the 105% legato (on slurred notes) is applied to the 85% default.
The best test of this would be a wind or string instrument such as a violin or flute rather than a struck instrument like the piano.
Nonetheless, I usually set my standard note length to 95% or so.

I don’t recall any intentional change in behaviour of this recently. Also I think that we have automated tests to check this. However, there’s another could of things that may affect this: if you have humanisation on them that will change the positions by small amounts, and secondly if you’re looking at successive notes at the same pitch then those won’t be lengthened beyond 100% because that would cause overlapping notes, which would lead to notes dropping out

OK, here’s an extreme case. Normal note duration set to 50%, Legato duration set to 150%, humanize set to 0.

Note that the legato notes are showing actual durations of 75%. Looks to me like you are multiplying the legato percentage by the normal note actual rather than the normal note notated duration.
test.dorico.zip (393 KB)

For completeness, I checked the other note duration timings (staccato, staccatissimo, marcato, tenuto). These are all computed as a percentage of the notated duration which seems correct.

Sounds like this is a change in behaviour. I’ll have a look next week.

sounds related to: https://www.steinberg.net/forums/viewtopic.php?f=246&t=110733&p=606915&hilit=legato+105#p606915

Not sure if there was a fix for this ever, but I’m still seeing an issue. I just loaded up the standard Baritone instrument with the HSO “Horn Combi” it automatically loads with (there’s no Legato playing technique in the Expression Map) and I had to set the Playback Options “Legato notes” duration to 125% to see any sort of overlap between notes in Play Mode. The 105% default is still playing detached.

As it happens, we have just fixed this issue today, so the fix will be included in the next update. Sorry for the inconvenience in the meantime.

Excellent - thank you Daniel and the team!