Length of cue note area

Hi folks. If I have read correctly in the manual, the way of adding cues is to select a section in the “target” staff, and via stift-U state what staff that should be the “source” for that section. In the following example, I selected measures 71 and 72, and executed the cue. But the cue section has the extension 71-78 ( or actually beginning of 79, see the little red rings) instead of the expected 71-72. This has the annoying consequence that whole rests appear on the cue line in the target staff. Sometimes, the cue length is set according to initial selection, but in I guess about 50 % of the cases, this happens. Any ideas?

In this case, the length of the cue is being determined by the length of the slash region you had selected.

Ok so how can I set the area I want to set and avoid the whole rests?

I’d suggest showing the caret at the position at which you want the cue to begin, creating the cue via the popover, which will give it a default length of one quarter note, then use Shift+Alt+right arrow to extend it as needed.

Ok. Can I ask…do you know what is the reason for this design?

It’s a quirk of how slash regions work. They are a single item that span the entire region. It’s tricky to take into account which specific noteheads within the slash region you have selected when creating something, so at the present time Dorico doesn’t do that. However, it’s something we may well change in a future version.

Ok thanks for that explanation. I hope it will be fixed soon, since making drum parts takes about 50 % of all editing time for my charts (and I haven’t yet started with the long process to try to fix the “Play X” areas for the latest one…). One final question, what do you mean by "“show the caret”? Does this mean that I need to drag the slash region handle one step to the right? That handle is often very difficult to get in control with the mouse, sometimes it just refuses to move no matter how large I make the view… Or is there another way to “show the caret”?

This is the caret - you can show it in a few ways, with Shift-N (for “note input”) being probably the most reliable key command and double-clicking on a staff being the quickest way for both bringing up the caret and automatically positioning it where the mouse was.

Within a slash region, selecting a single slash and pressing Shift-N should activate the caret at that position.

Ok I know fairly well what the caret is :smiley: I was not sure what was ment by “showing the caret” when dealing with slash regions. To drag their extent is a pain… But great I use the shift-N again for this situation, thanks for that explanation. When dealing with regular note input I have switched to using only “Return” since this is simpler and more straight forward. Almost forgot the shift-N thing…

Great, sorry to have regaled you with known information but yes that’s what people mean when they say “show the caret” (“bring up the caret” “activate the caret” “start note input”).

The only thing really to be aware of with Return is that if you’ve selected e.g. a dynamic, tempo mark or similar, then Return will open the popover for that item rather than start note input. So personally, I almost always use Shift-N when I want note input to be safe/consistent.

Ok thanks for help and good advice.

1 Like

Hi again,

I have big problems again with cue notes in drum another drum part. Last time I really did not make your method of " showing the caret at the position at which you want the cue to begin, creating the cue via the popover, which will give it a default length of one quarter note, then use Shift + Alt +right arrow to extend it as needed" to work and I needed to finish so I edited every single cue by hand (select the drum area where there is something in the “Tom” part, used shift-u to create the cue, then manually edited so that the cue label was not displayed (actually I have some recollection that cue labels could be turned off but only globally and I needed them in other parts so I hade to do it this way).

So now, with more time I tried what I hoped are better methods than edit every single measure with cues in it.
Method 1) I left most of the drum part empty, adding cues only to the “tom” part for the full piece. Then selecting the full drum staff, adding cues with “shift-u” from the “tom” part and all showed up. Simple and time efficient. Big problem: all whole rests comes with it.
Method 2) The method you proposed with adding a quarter long cue from the caret and then extend it with the shift-alt-right arrow. Tried that for about 30 bars (the piece I am to conclude is about 200 measures) but whole rests are still showing up where there are no cues in the “Tom” part.

Both methods give the original post appearance, with whole rests in the “cue” position of the drum part.

I really must check here if I misunderstood something (or if I have forgotten something, it was some months ago): should I expect the whole rests when using the “extend” method you proposed?


EDIT: Now I can’t find how to turn off cue labels It should be in the Engraving Options according to the manual but I can’t figure out how to configure so that they are not displayed at all. Could use some help on that one too. Thanks //D