Level meter overshoots on right channel

It seems the new EBU Level Meter has a problem on the right channel. When the meter is set to “True Peaks” the right channel peaks overshoot by several dB.

These overshoots only show up on the right channel of the meter and do not show up in the master section meters or other plugin meters I have tried.
Wavelabe EBU overshoot.jpg

You are (almost) right. What happens is that the right channel shows the maximum peak of both channels, rather than the right channel peak alone. This only happens if the setting “True Peak” is activated for this meter (which is not the case by default). This will be corrected in next update.
Note that this is not the “new EBU Level Meter”, but the “standard level meter with the new True Peak option”.
The new “EBU Loudness Meter” is another meter.

I am not seeing a way to turn the True Peak display (combined number in the lower right hand corner of the horizontal display) off in the Loudness Meter (which is I assume what you mean by the EBU meter). Since it is separate from the other values being displayed, this makes sense to me.

I do see a way to turn it off and on in the Level Meter, so perhaps that is what you are referring to in the post above. Perhaps you should address the fact that there seems to be no indicator in the active Level Meter window that the True Peak function is turned on?

…And, on my machine, when I choose the True Peak option for the Level Meters, left and right display exactly the same numbers as left and right in the Master Section meters with True Peak engaged.

Perhaps you should address the fact that there seems to be no indicator in the active Level Meter window that the True Peak function is turned on?

Right.