Lexicon 480L hardware reverb has 170 ms latency. Compensation in Cubase is 100 ms max. How to do?

Hi! I’m a proud owner of a Lexicon 480L hardware reverb.
When I do the ping test, the delay compensation is set to 100 ms because it is the maximum Cubase can do but when I print a track through the 480L, the latency is in fact 171 ms (8212 samples at 48kHz).
Is there a way to manage that and apply a 171 ms delay compensation to the 480L?
Thank you!

I dont know about your hardware routing, also I am ITB and if you get PDC limitation in cubase can you try:

Melda utility (free) and you can check option “report as latency” and check if u have any success


Yes, that’s a great idea!
I’ll try that.

480 can’t be that slow! Did you check pre-delay settings?
A lot of reverb programs have pre-delay set to a large amount, it’s not always the same but some have a big amount like that. The remote is a bit strange and tricky, you have to get used to it.
You know, it was used in a lot of studios worldwide, if it had such a big delay, it had never reached that state. The latency of A/D D/A and processing must be less than 5ms in total or so.

Besides, you can move a channel ahead by using this plugin;

Ping still shows 100ms but as you already know the delay, you can set the amount to this plugin followed by the external effects set to 0ms.
However, I recommend you dig into the programs and set the pre-delay.