Lexicon Omega loaded, but not working ???

sooo…today i decided to try to get my Omega to work since it has a win7 driver, and i need a decent input or 2 to get me by till i can get a newer interface.
so, i reset it and go into the devices and hook everything up, and all looks perfect…even says i have an omega midi connect…
then, when i go to try it out …nothing works…of course.
tried a new project and also another ive been working on and nothing.
no meters, no sound, no metronome…nothin.
ive also restarted cubase and tried again after loading the omega.
ive been running flawlessly with asio4all v2 , but i refuse to record anything im gonna keep with a computer mic jack…i can SEE the poor quality in the audio activity meter!
anybody got any idea why this isnt working?

Set up correct buses in VST Connections? Correct buses selected on the tracks and main out?

ya, ive set everything.
i switched to asio4all driver, and now i can input midi with a keyboard,
but still no playback or sound at all…

Can you listen to ordinary mp3s/streaming audio etc. on your PC?

Have you checked the VST system link?