LFO Monitor BUG

Discovered another bug today. The “LFO Monitor” parameter does not seem to report anything at all. I didn’t take the time out to confirm this with any other zone besides the synth zone. This bug is not present in the “Phase Monitor” parameter within the midi modules. Here’s how to create the bug (Using Windows 10 64bit)…

  1. Launch Halion 6.
  2. Hexagon loads… Right-click the program (Hexagon) in the slot rack and click Init Program.
  3. Click the ‘Open New Window’ button and select ‘Macro Page Designer Extended’.
  4. Click the ‘Create A New MacroPage/Library’ button and Select create a ‘Halion Sonic Macro Page’.
  5. Navigate in the bottom browser panel for any knob template and drag it into the visible macro page area.
  6. On the right side, navigate the program tree to and left-click the Synth Zone.
  7. Navigate in the parameter list for “LFO1Monitor” (Roughly 15 spots down)
  8. Drag the “LFO1Monitor” Parameter from the Parameter list (on the right) onto the knob template (created in the previous step) to connect the two.
  9. On bottom right SOUND panel, scroll down to the mod matrix section and set the first mod matrix slow to LFO1.

At this point nothing happens. What should happen is the Knob should cycle over and over again imitating the movement of the phase of the LFO but it does not happen.

To see how this is supposed to work.

  1. Change LFO1 in the mod matrix to Modulation Matrix LFO 3
  2. Left-click LFO 3 in the Program Tree.
  3. Drag the “PhaseMonitor” Parameter from the Parameter list onto the knob template.

The knob should instantly begin to move with the phase of the LFO.

Over 500 views. Common SB. You guys got to see this.

Whelp, looks like this is not a bug. Figured it out. It operates a bit different due to the polyphonic nature of the LFO. It must be mapped and actively triggered in order to actually work.