Libraries available in Windows Administrator account but not in Standard User

Hello… I’ve HALion 3.5.10.153 installed on Win 10 machine.

When I am logged in with my user profile, and I open Library Manager, I see the expected libraries. When I launch HALion, the libraries are there as expected.

When logged in with my daughter’s profile on the same machine, and open Library Manager, I have to enter Admin password for it to launch… when it does, I see all the expected libraries. However, when launching HALion in this profile, there are no libraries.

How to make the libraries available on this shared machine for her in HALion? are these libraries somehow licensed to one user?

I would presume that the daughter account would need the same privileges as your admin account.

What privileges specifically are needed by Steinberg software to enable a teenager to use the libraries? Obviously, I don’t want to give her full reign on the computer as a full admin.

I guess you mean Halion Sonic SE, because “Halion” is a different product.

I just did the following

  • Created a Standard User Windows account
  • Logged in to the account
  • opened Halion Sonic SE 3

All presets were available, so on my setup, different privileges or permissions were actually not needed.

Sorry I don’t have anything else to advise – I tried to duplicate what you described, but the result was not the same.

What products do you use the content in? This topic should be posted to the corresponding category. It looks like that is Dorico, so I’ll move it. (the Halion category is for Halion.)

Ok… thx. Yes. It’s HALion Sonice SE with Dorico. Tried reinstalling and even made her an Admin… no dice.

I’ve moved the topic, maybe someone on the Dorico side can help.

Thanks @steve ! Dorico peeps… please help! I’m attempting to get my kid hooked on your product!

With the new licensing introduced with Dorico 4, the license is indeed tied to a single user. I don’t know if another user account can use one of the 3 system licenses available. Call up the activation manager and see if you can register under your daughters account.

Dorico is activated, and runs fine. It’s just the sound libraries that fail to show up. There’s nothing specific in the Activation Manager related to the sound libraries, or even HALion SE… just Dorico.

I further tried this:
Deactivated Dorico 4 Pro
Created account for daughter (though, not sure what the minimum age for that is, wasn’t asked when creating an account, and when reading the terms, searching for ‘age’ only said important reasons license could be revoked would be due to below unstated minimum age, and thought perhaps was being blocked from sharing account, which understandably is also a no-no).
Activated Dorico 4 SE
Installed Sound Library (for the 4th or 5th time)
Still no Dice.
Though, it still seems that Pro is running under her account… as Engrave mode is there(??)

From Windows’ side you have to give your daughter’s account the same permissions as your own account. So go to c:/program data /Steinberg /contents and change the permissions for everything in there, that means also subfolders.

1 Like

Well… tried two things… neither worked.
Made her an Admin of the machine
Modified the Steinberg folder security (and all sub folders) ensuring she had full control over everything.

Then force a rescan. In the Dorico preferences is under the VST tab at the bottom a button for resetting the cache (there are two, push the most radical one) and then restart Dorico. Still the same?

Still nothing… Even taking Dorico out of the equation, nothing shows up in HALion SE 3 standalone.

One last attempt then:
Under your daughters account, stop running any Steinberg program.
In FileExplorer navigate to %APPDATA%/Steinberg.
In there delete everything including every subfolder, except for the Activation Manager folder.
When you then start Dorico or HALion Sonic Standalone, still the same?

Made no difference.

I had the idea of attempting to use a different VST to see if I could get that to work. So, I loaded up Kontakt, which again, works fine when logged into my profile, but when my daughter is logged just after the Kontakt VST is added to the rack, Dorico crashes.

Attached screen shot and crash dumps.


Dorico 4 AudioEngine 5.0.30.156 64bit 2022.8.20 16.40.dmp (622.9 KB)
Dorico 4 AudioEngine 5.0.30.156 64bit 2022.8.20 16.44.dmp (662.1 KB)
Dorico 4 AudioEngine 5.0.30.156 64bit 2022.8.20 19.48.dmp (661.6 KB)

I also created another new user on the machine… it has the exact same issues as the original child’s account.

Those 3 crashes are all in Kontakt, so I can’t say anything about what is happening on that end.
And if that what I suggested also did not work, then I am also at the end of my wisdom. Sorry

Hi @Ulf - thanks for looking at it. They may be in Kontakt, but it ONLY happens when using as a plug in Dorico used as vst3 which is a Stinberg standard, failing at the same point as Steinberg’s own HALion SE instrument (though HALion is silently failing not explicitly crashing)

@Ulf - what might you suggest as next step to escalate?

Note: I did find a work around… under the child’s profile, if Dorico is run as administrator, both Kontakt and HALion SE work fine within Dorico. Since I will be away this week, I setup my windows pin so she can use it that way…. (I didn’t NOT cut off my finger so she could just use the finger print scan as she had suggested… though in retrospect we could have entered her finger as one under my profile… :rofl:).

Yes, VST is a standard defined by Steinberg, but it is just a defined interface with a description of how the implementation has to behave. When a plug-in vendor takes that interface and implements it badly and has crash bugs, then not the hosting application (in this case Dorico) is to blame, but the plug-in.
When a plug-in crashes, then it will take down the hosting process and it can’t do anything against it. Also solving the crash issue can only be done by the plug-in vendor.
I guess - and that is only guessing - Kontakt crashes because it can’t read in contents files.

That it all works under administrator rights proves my point that it must have to do with wrong file access permissions. Even though you said that you already checked, but I would double check, especially on a file basis and not just folders.