Licence download failed

February 20, 2022. I’ve been trying to activate the Hybrid Bundle license via eLicencer Control Center (latest version) for days, but without success. The License Download gives the same error every time: “A connection to the license server could not be established, either due to incorrect network settings, or because the license server is currently not avaibalble (e.g. due to maintenance work).” My network is working fine, the firewall is not blocking eLicencer. So what’s going on? I read on the forum that more people have this problem, but I don’t see a solution.
Online synchronization & Maintenance of eLicencer also produces similar error messages. The previously purchased licenses for eg. Cubase PRO 11, are properly displayed by eLicencer.

What is going on? This hassle with activating Steinberg licenses is really annoying!

Is your eLicenser software up to date?



Hi Steffen,

Yes, I use the latest version for Windows: elC Version I start eLicenser Control Center as administrator.

Maintenance gives this errors:

Step 1: FAILED (Updating eLicencer Licence Database)

Step 2: OK (Repairing Soft-eLicenser)

Step 3: OK (Validation License Usage Periods)

Step 4: OK (Cleaning up eLicenser Memory)

Step 5: FAILED (Recovering License Transactions)

Step 6: FAILED (Sending eLicenser Information)

With regards, Pieter van Dijk



same as mine, and it worked the last time I tried… have no dongle with me can’t check it now
Without any license, it reports no failures.

10 days after the support-ticket about failing eLicencer, still no reaction from Steinberg Support …

Unfortunately, I had to request a refund after waiting unsuccessfully for support to activate the Hybrid Bundle. Too bad, I was really looking forward to this software, but apparently support isn’t that important to Steinberg.

Oh, btw, you posted this in the German part of the forum.

The problem is finally solved. It turned out to be VPN blocking the download of the license, even though the firewall indicated that eLicenser was able to access it.
Thanks for the support.