License missing after update attempt

Hi,

I purchased Cubase 12 update earlier today. I went to apply the code via the Steinberg Download manager. I selected Cubase 11 as available license to update then I got various error messages about connection fail. I tried a couple of times then my dongle doesnt show my Cubase 11 license anymore and I can’t apply the update. I can run Cubase 12 using the new licensing system but what about my dongle license?

Thanks,

Antonio

1 Like

same to me

edit : oh I just check and now I have this

1 Like

Update: now i have Cubase Pro 11 (Not upgradable). Is this normal?

Yes. Exactly what you should be seeing.

2 Likes

Hi everybody
I try to upgrade my cubase 11 to 12 with steinberg activation manger when I press the button , check for grace period it didn’t find nothing and deleted my cubase license from my dongle. I tried to press the maintenance button but it stuck,
I have recording session tomorrow morning
please help

I have the same problem

@Jakub_Kaspar but @lanuitbelle reported that it is working.

I have the same problem, currently my eLicencer doesn’t show any licence (it has show earlier today, but showed that it’s being transferring), also my Activation Manager shows no licences. In my Steinberg Account (old version) I can see my licence, but in new one, it doesn’t show any also. I can’t connect to server via eLicencer, it fails at phase 1,5,6. Due to deleted licence in dongle, now I can’t open Cubase 11 too. (I bought the Cubase Artist 11 upgrade with free Cubase 12 update, and really stuck with that situation now)

I received my key on the email, but now the activation step doesn’t work …So yea, we just have to wait a bit more guys! Hang on

That’s the server being overloaded…

solved, at the end, I just had to wait , hehe ! Thanks to the team for their patience ! Everything works well now