[Likely SOLVED] No playback on my M1 MacBook pro without Rosetta

But that is a version 3.3, not 3.5

It get’s more strange the more I look… I suppose I can delete it.

Ah, and that is the standalone application, not the plug-in.

If you never use it as a standalone app, yes, you can delete it.

I’ve never even seen it before. It’s not installed on my Intel Mac.

Well, thanks for your help, Ulf. It’s 3:43am here so I’m going back to bed.

1 Like

Thanks for the suggestion. I’ll look to see what’s there. Ultimately Ulf came up with a solution.

Well, I thought the problem was solved. But I quit Dorico Pro 4 and then at work relaunched it (Not in Rosetta), and sound would not playback until I quit Dorico and set it to run using Rosetta. I’m unsure how to proceed from here. The easiest thing for me to do is just rely on Rosetta and forget about running Dorico natively on an M1 mac.

Perhaps you can check what version of HSSE you really have installed. I just suggested this for another user:

Here’s a screenshot:

it looks like I have HSSE 3.5.0.137

-t

With that version it is supposed to work. Please try following:

  • Start Dorico in native M1 mode and create a new project from piano template.
  • Go to Play mode and open the HSSE editor window
  • Click with the mouse on the on-screen keyboard, is there some metering flickering then in the HSSE window?
  • If yes or no, in both cases check under ‘Edit > Device Setup’ what ASIO driver is selected.
  • Also check there if the correct stereo output pair is selected
  • If still no sound, please do ‘Help > Create Diagnostics Report’ and post the corresponding zip file here.

Thanks

Dorico Diagnostics.zip (486.4 KB)

Hm, the log files look quite okay. Audio ports are there and correctly mapped and also everything else looks fine. How about if you enter a signature, e.g. 4/4 and add e few empty bars. If you then hit Play, does the playback start then and can you hear something?

Tried that. No joy. I even reset the playback template and that had no effect. I could input notes via mouse, computer keyboard, and virtual keyboard but there was no audition of the notes on input nor was there any playback. I restarted the machine. No change. The only change comes when I start DP4 in Rosetta. Then everything works peachy.

Seems to be working now although the solution is not clear. Ulf did a screen-sharing session and I had to install Zoom for that to happen. Perhaps that goosed the audio system but with his magical presence, DP4 started working in native mode. Wish I understood why…