Limit Key Range of a MIDI instrument


I would like to know if in Cubase there’s a way to limit the range of notes that I want to play in a midi channel.

This is because I want to play a bass and a piano and other instruments at the same time and limit the ranges of notes of
every instrument.

In Logic there’s an option called “Key Limit” where you can setup every channel.

I was checking the different midi tools and options but I can’t find anything.

Thank you so much.

Hi - what exactly do you mean by “I want o play a bass and a piano and other instruments at the same time” - I mean, at which step do need to limit the range of notes to accomplish that?

I think there are good solutions for your request, but I do have to understand what you actually need. (I mean, “everybody” has Cubase playing multiple instruments at the same time…).

Hope to help… ernst

in the inspector : tab Midi setup or Midi config

HomeStudio87 … which of them allows what exactly to solve which of the problems of the OP?
I just want to understand. To me his szenario is not clear.
If he has e.g. and external keyboard without split-capability and wants to control 2 instruments in cubase at the same time - separated by “splitpoints” in the noterange, he would need the input transformer on the relevant tracks in order to filter out the not relevant notes, doesn*t he`?

not oblige to use “input transformer”. simply add 2 or more intruments track, and on each track n the inspector open the tab “Midi Modifier” and at the bottom “Range” select “Limit Note” and choose your note range for this track… do it for each track and now you’re able to play 2 or more different instrument in your keyboard range zone… (some pitch setting on instrument must be edited perhaps)

HEy you, great - I ve learned something!


Me too. I’d have gone for the Input Transformer without even thinking about it.

Thank you so much. Finally is working but if I use “Limit Note” is not working well and I need to use the option “Filter Note”.
With the “Limit Note” when I play a note that is outside the range that I marked there’s a noise and there’s no silence but with
the “Filter Note” this don’t happens.
So perfect and than you so much to all for all your explanations and help.