Lines and empty slash regions

Hi,

It seems that the (otherwise wonderful) implementation of lines does not yet work well with empty bars marked as a slash region.

A lead sheet I’m working on includes a lot of empty bars defined as a slash region. I’m trying to add a line attached to a rhythmic position indicated by the slashes in the slash region - like in the attached screenshot.

I select the slashes above which I’d like the line to appear, click the line symbol - but the line is drawn above the entire slash region instead of above the selected area. Similarly, there’s no way I can move the line start/end markers to the correct location (in the attached example it would have made sense to at least allow modifying the line start/end position in quarter notes, where the slashes appear).

I ended up adding dummy notes where I wanted my line to start and end, but this looks like something that needs to be fixed.

Thanks,

Uri

Thanks for your feedback, Uri. This is difficult for boring technical reasons, but I agree that in an ideal world you would be able to create a line at the selected duration of the slash voices. You might find it more convenient to create the line with no selection, i.e. start with nothing selected, click the line in the panel, and click into the score. You should then be able to set it to the desired duration with Shift+Alt+right arrow.

Thanks Daniel, the workaround you suggested is useful, particularly for short slash regions (when a long sequence of bars is marked as a slash region you’re going to spend a lot of time hitting Alt-Shift-Left Arrow :wink: ).

I want to be able to insert a line below and empty stave, so that the line starts on beat one of the first bar (no problem), but finishes on beat 3 of the following bar (doesn’t seem to be possible. Is there a workaround?

Like this?

underline.png
I added the (Rhythmic Position) line to the first measure and then ALT+SHIFT+RightArrowed it to lengthen it to the third beat.
underline.zip (513 KB)

Hi Derrek, Mmm. I tried that but the end of the line shot to the next bar with something in (an 1/8th note rest as it happens). I’m not sure what you mean by “Rhythmic Position” line. I had “rhythmic position” selected at the top of the lines column before I selected the line I wanted. I also see in your example that when I press Alt+Shift, the rhythmic grid shows up, whereas it doesn’t in the example I am working in.

For that matter, I can’t make any changes in your example using Alt+Shift+Arrow, so I must be doing something wrong but I can’t figure it out.

It sounds as if you have interpreted my reference to a rhythmic-position line correctly, since some lines go from note-to-note, and others stretch from barline to barline.

Once you select the line (not the caret, the line itself), the ALT+SHIFT+ArrowKey lengthens or shortens the line based on the rhythmic grid “pull-down” (actually a pull-up in this case) set in the lower left corner of the Dorico Window. Mine was set to eighth-notes, so even if I did not see the grid, I could count my keypresses to gauge the ending beat.

Hi Derrek, thanks for your help and for bearing with me on this. I’m obviously still not doing something correctly. I didn’t know about the grid setting in the bottom left hand corner. I’ve set that to 1/8th note. But all that happens (in my score) when I press Shift-Alt-RightArrow is that the right end of the line leaps to the next bar with notes in (actually 5 bars on. When I press Shift-Alt-Arrow in the example that you sent me, the grid appears above the stave, but - nothing happens! I can neither lengthen shorten or lengthen the line in your example.

Perhaps someone more adept than I at animated GIFs than I can make one to show you the process. I am not sure how to explain more clearly what I have done or to understand why you are not getting the same results.

JanSteele, do you encounter the same behaviour in a brand new project with just one staff and a couple of bars? If the problem appears to be specific to your present project, please consider zipping it up and attaching it here.

do you encounter the same behaviour in a brand new project with just one staff and a couple of bars?

Yes.

These are the procedures I followed.

  1. Create the project in the regular way
  2. Add a few bars rest
  3. Select the first bar rest.
  4. Select a line.
  5. The line appears linked to the first beat of the first and second bars.
  6. Set the grid in bottom left hand corner to 1/8 note.
  7. Select the line in the score
  8. Hold Shift-Alt and press right arrow key. The grid lights up above the stave, but otherwise nothing happens.

I guess I must be missing something out but I don’t know what.

Here is the latter test project
Lines test.dorico.zip (530 KB)

I had no problems extending the lines in your file. If you are on a Mac, are you using SHIFT+OPT+Arrow to extend the line?
Are you using a non-English keyboard?

lineTest.png

I am on a Mac (10.14.6) and I am using a standard English Mac keyboard. At least I assume that it’s standard - I’ve been using it for about 8 years. I’m using Shift+Alt+Arrow

Does the Alt above option on a Mac require the use of the function key? (I’m trying to avoid switching the dongle to my Mac to test your file there.)

Nope. Alt/Opt-Shift-Right arrow works fine here on a (multiple) Mac(s).

JanSteele - does Alt/Opt-Shift-Right arrow work to lengthen notes by the grid value?
if not, search Preferences > Key Commands for lengthen, then check what you see for Note Editing > Lengthen Duration by Grid Value.
It ought to look like this:

Derrek. No a function key is not necessary.

pianoleo - In any project that I create, Alt-Shift-Right doesn’t move a line.

In the Key Commands window, no key command shows up as it does in your screenshot. Screenshot attached.

In the attached test project - I am able to move the upper line using the key command. The lower line I cannot move at all.
Lines Test and Key Commands.zip (671 KB)

Try assigning that keyboard shortcut (Shift-Opt/Alt-Right arrow) for the Lengthen Duration by Grid Value, then try using that shortcut to extend the line. The shortcut should be set by default…

Ok I’ve fixed it. I had to reset the Key Commands. I don’t really know why this was necessary, but when I had done that I was able to see the key command for Lengthen Duration by Grid Value, and finally it worked! Thank you everyone for your help.