LINK : fatal error LNK1104: cannot open file 'C:\VST_SDK\VST3_SDK\build\VST3\Debug\again.vst3'

I just got caught up with the SDK 3.6.10 and have an issue with Windows 8.1/VS2015/2017 (have not tried Win10).

For MacOS, running CMake on the sample project code works fine and plugins build; the resulting bundles contain a shortcut to the .vst3 plugin and work properly in Reaper - everything is good.

For Windows and VS, running CMake builds the .sln file. The sample projects all compile and pass the validator. I can see the .vst3, .ilk, and .pdb files populate the /Debug folder, as normal.

Then, the projects fail with errors like:

LINK : fatal error LNK1104: cannot open file ‘C:\VST_SDK\VST3_SDK\build\VST3\Debug\again.vst3’\

This happens right after the new “bundle” folders appear in the /Debug with identical names as the .vst3s they are trying to package.

The resulting .vst3 DLLs will appear as VST3 plugins in Reaper if copied to the proper folder.

But the bundle folders don’t contain anything other than empty folders, Contents/Resources/Snapshots (all empty) and I’m not seeing the other subfolders as described in the documentation, for example:

Contents/x86_64-win <-- does not exist

I suppose I am doing something obviously wrong - any ideas what’s going bad here? I’m guessing it is something simple. I’ve tried building from Visual Studio as well as from the command prompt, and VS2015/2017 on two different computers with the same issue.

Thanks in advance,


For those who have also been stymied by this, the answer is to manually enable the SMTG_CREATE_BUNDLE_FOR_WINDOWS flag when running CMake. Found the solution here:

  • Will