Linux Support Steinberg UR22

Looks like the patch is officially in the Ubuntu 14.10 tree now:
http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-utopic.git;a=blob;f=sound/usb/quirks-table.h;h=c657752a420c024aba8c61fa8ced9b8971434fcf;hb=HEAD
I just ran the Ubuntu update, and the UR22 worked out of the box on reboot.
:mrgreen:

I have a Steinberg UR44 and tried the same procedure in Ubuntu 14.10. When that didn’t help, I edited the quirks-table.h in analogy to KgwgK’s patch file and thereby duplicated the UR22 entry, replacing the idProduct for 0x150e (which I took from lsusb). Then I repeated the steps of KgwgK’s bash script (make, disabling snd-usb-audio, rsync, enabling snd-usb-audio). Unfortunately, even after reboot the device is still not listed as a sound input device in Settings > Sound. Any idea what went wrong?

I’m not sure, after looking at these threads, but it looks like Cyrus was able to get it to work.
Are you sure you didn’t re-apply the patch file with that script and overwriting your UR44 changes?


http://permalink.gmane.org/gmane.linux.alsa.devel/130021

Yes, I’m sure.

However, apparently it did indeed work but the device is only recognized if it’s connected at system start. Reconnecting it later (including off/on) is of no use. Another caveat is that in Settings > Audio it’s only listed as an output device while, luckily, Audacity lists it as both input and output. A fast test showed that with a six-track recording the microphone input in channel 4 is detected correctly.

Hi,

I am just trying to get my UR22 working on Ubuntu 14.04, Kernel 3.13.0-44. The UR22 was recognized out of the box as Input/Output device. However, when using it with Jack and Ardour 3, both Mic/Line inputs of the UR22 are recorded on one channel. Couldn’t figure out yet how to do stereo recordings…anyone managed to use both channels for recording in Ubuntu? Hope it’s only a configuration issue…

Best
Chris

EDIT: Problem solved: The UR22 needs to be connected before systemstart (as quoted before) AND it must be conntected to an USB 2.0 port.

I hope this helps somebody

I tried the UR22 on Ubuntu Desktop v15.10 and it works.

All I did was power down the machine, plug in the UR22 USB cable into the computer and turn it on.

I did not have to install any device drivers or software.

The UR22 was recognized automatically by Ubuntu 15.10

Yeah, I got the fix into the kernel, so all is well now. :ugeek: A few other distros picked it up as well, although I haven’t tested all of them.

Glad it works for you !

Hmmmm… wonder if this works for a UR44?

Would love to know this too if the UR 44 works in Linux. Did somebody try it out yet?

This is great news KgwgK, thanks heaps for this! :sunglasses:



Did you guys get a chance to try it out?

Edit:

I was browsing the ALSA mailing list (see link below), and it looks like the UR44 has a “CC” (Class Compliant) button in the back that you can press, and it shows up as a multi-port IO device, and doesn’t need the UR22 quirk patch…
Can anyone give this a try before I go out and buy a UR44 to test with ?

http://mailman.alsa-project.org/pipermail/alsa-devel/2015-July/094403.html
http://www.musictech.net/2014/04/steinberg-ur44-review/

Ok, I went out to Guitar Center and bought a UR44… $$$ :confused: :cry:
Audio output works out of the box on Lubuntu with the “CC” button pressed in the back of the unit.

Haven’t tested any mixing, recording, etc, yet, but will update the thread later.
Enjoy !

Thanks for the update. I have not had a chance to get back into the studio for a while now. Sustained an injury to my right hand which has impeded getting other things done… Interesting news about the CC button on the 44, that is normally intended for iPad use, looking forward to having a go. Also your results will be good to know. :sunglasses:

So, did anybody tried the UR22 with the newest release of Debian or Mint? I am planning to replace Ubuntu soon with Debian or Mint. I would doubt for Debian, since it is supposed to be very stable but packages don’t get updated so quickly.

It is nice to know that the UR22 is now recognised out of the box on some distros!

I am stuck until January, no time. :imp:

I tried with Debian 8 (Jessie) and it works out of the box. No configuration or anything to do.

Yay!

But I have kernel version 4.4. I had a weird issue with my GPU and the only way to make it work was to upgrade to kernel 4.4. Debian 8 ships with linux kernel 3.16 and I didn’t even think to try the UR22 before upgrading.

I didn’t try to record anything though, but UR22 inputs and ouputs are listed in the Sound configuration panel of Cinnamon. I just played a song on Totem.

Hi everyone!

Can I do something with my Steinberg ur28m on Ubuntu?(
System dosn’t “see” audio outputs, at that audio inputs are identified(i don’t check it).
I just need to listen audio.

Here is screenshot from alsamixer.
It’s russian language - but i think you undestand it.

HI. I have been using my UR22 (Mk 2) successfully with Ardour running in Linux Mint 17.3. No such luck running it with Ardour in Elementary (as yet). Ardour recognised the interface straight away and I set the UR22 as my input and output. Having recorded guitars a few nights ago I then downloaded the calf effects as my plug-ins and they work a treat as well.
I have not downloaded any drivers and am not running anything through WINE. The UR22 just works

I’m using Arch Linux, and even though the system is immediately recognizing the UR22, I’ll get this when I choose the Steinberg aus my soundcard in alsamixer

[Clock Source 41 Validity]

Can someone please help me or give me a hint? Are you using ALSA, Pulseaudio or Jack? Did you have to do anything to set it up?

Hi

I can confirm that the Steinberg UR22 MKII works well on Linux (Plug and Play).

Ubuntu 18.04 and Audacity. Just select the Steinberg as Input.

Hope this helps.

To anyone coming from search engines, I hope this helps out:

I have a UR28M interface and I’m running Debian 9. The USB interface is recognized and sound was coming out but there was reverb on top of everything and I couldn’t seem to change the volume of any of the channels without it resetting.

I managed to fix this by turning on Class Compliant mode, described in the manual here: http://download.steinberg.net/downloads_hardware/UR28M/UR28M_documentation/UR28M_OperationManual_en.pdf#G6.1032537

Turn on the device while holding down OUTPUT button C, and keep pressing the OUTPUT C button until an INPUT meter/OUTPUT meter flashes.The UR28M enters Class Compliant mode for Apple iPad connectivity. While in the Class Compliant mode, the power button flashes several times by pressing the power button. To turn off the Class Compliant mode, turn on the power while holding down OUTPUT button C again.

After doing that the reverb was gone and I could listen to audio normally.
Good luck!

Worked like a charm - thanks!