Little Issue in Score editor

I’m having a problem hopefully solved by some preference setting. But here’s the scenario.

I use the score editor quite a bit. When I select several tracks to view in order to edit the information, when i do any step input entry, I am hearing all of the selected tracks sound, even though the information is only being recorded on the track I’ve selected in the editor. Tis is a new problem for me, as it was not an issue on 8.5 or earlier.

Any thoughts?

Best,

Jay

I must be misunderstanding the problem, because it seems to be working ok here… I hear only the note that I am step-inputting (is that even English? :wink: )
Maybe you could describe a bit more fully how you are proceeding?

Sorry for any lack of clarity. Maybe this will help.

Let’s say I have a piano track and a flute track. If I highlight them both in the project window, open the score editor then decide to step input some notes, here’s what happens.

I first select in the score editor the track I want to put the notes in, say the flute. When I start to input notes I hear both the piano and flute sound, even though the. Pres only go into the flute part.

Does this help?

The behavior has changed! In C8.5 record enable follows the staff selection in Score edit when the Score editor has focus, so tracks are dearmed (I know that can’t be english :wink: )

In C9 tracks that are record enabled in the project window stay record enabled without regard to the staff selection in Score edit. Looks like a bug to me.

Confirm my repro and I’ll file a bug report. :smiley:

Repro

(Record enable follows MIDI thru should be active)

Record enable some tracks in the project window
Switch to Score Edit, a track is selected. Play some notes
–> midi thru is active on all tracks, tracks are still armed in the project zone.

First do you really select the “tracks” ? or do you mean the “parts” ?
If you select all the tracks (I don’t know why you should do that by the way), based on your preferences, they should all be record enabled, and in this case it would be a normal behavior.

Secondly, there is something new in the editors. On the top left side of the score editor window you have two new buttons : Solo Editor and Record In Editor.
Activating Record In Editor should solve your problem.

TheMaestro is correct! Can’t believe I missed that. :blush:

@Steve

“Even the greatest Masters can make a mistake someday”
TheMæstro

:smiley:

I did have “Record in Editor” enabled here (just tried again, and, without it, it step inputs to the track that is selected in the Project window, irrespective of the staff that is currently active in the Score Editor).

Thanks TheMaestro. I believe that has solved my problem.

J