live midi playing

I need some help on a small issue:

I recently trashed preferences because I got tired of windows that were stuck outside my screen etc, you know the deal. I had no backup, so I’ve been going through all the settings to get things the way I had them before trashing them.

I got everything the way I want, but 1 thing: I used to be able to play any soft or hardware synth using my keyboard by simply creating a miditrack, setting the output to the desired device and I could play. Now it won’t play untill I arm the miditrack with record enable, and only after a few seconds delay as well.
Recording and playing back midi works fine regardless of what I set it to, it’s the live midi playing that seems affected only.

Any suggestions?

Use input monitor instead and retrospective record and only record when you need preroll.


Is input monitor the orange speaker which you also have on audiotracks? If yes, I tried that and it makes no difference. tbh I have no idea what that’s supposed to do anyway, but that’s a different story.

I don’t know what retrospective record is and I never use preroll. Anything I should know? :confused:

The input monitor button will only work if there is MIDI input, but with midi interfaces it’s all or nothing, so are you seeing any input in the transport bar?

Don’t listen to brains. :wink:

The monitor button should be all that’s needed to listen through a VSTi. Is MIDI Thru enabled in Prefs?

Which is what I said, so how about answering the OP’s other question as you have done in the past for me or is it too much a stretch of your goodwill?

Thing is brains, and I don’t know if it’s just me, but I can’t actually understand 80% of anything you write!!!

Shouldn’t that be write? :confused: :mrgreen:

It’s not just you, it’s his modus operandi. He’s quite good at it, too. Hard to sprinkle enough technical terms on top of the bollox to keep the mods fooled. :laughing:

And you thnk Chris B. and co. are that simple do you?

Yes you’re right :laughing:
It’s late here but I did manage to correct myself before you pulled me up :mrgreen:

Surely your go go gadget browser has spell check? :ugeek:

Yeah but it doesn’t have a context checker and anyway I dont always ues a spell cheacker :mrgreen:

Maybe you mean spell cheeker :laughing:

Irony my man…

Midi Thru I tried both settings and that made no difference. The monitor button doesn’t seem to do much either, weirdly enough. I’m also very sure that I never had to press it before.
It occured to me that maybe it’s because I used ‘record enable selected track’ on before, but I still fail to see what record enable has to do with sending out the live midi data.

For the record: Midi data comes in fine, it records fine and it plays back fine, it just doesn’t play back when I play my keyboard with a midi track selected.

BTW Split, I preferred your atom picture, you look too much like brains now :wink:

I have always had to select the monitor button to enable “live” midi through a channel! I don’t have record enable on selected activated.

May just be worth re doing the prefs again!!!

The Atom will return, Inspector Gadget is my tribute (time limited) to brains (mysteryshopper) and his unintelligible scribblings, maybe it’s a translation thing?

In fact I think I’ll go change it now, It’s funny how an avatar can affect the perception of a posters intent. :laughing:

Maybe you can use a midi interface with pass thru such as the roland range.

I quit using computers as midi tools ages ago.

I have always had to select the monitor button to enable “live” midi through a channel!

Right, that’s really odd then. I could always just select a track and start playing right away. I’ll go through everything again, maybe I missed something.

@ Mysteryshopper: I have considered this in the past, but that wouldn’t work because most of my hardware has just a single midi input. If I want to play the hardware from recorded midi (cubase) and live I can’t have both, unless I don’t understand it right.

My X-station for example has both usb and standard MIDI, so while the USB actually records the data, the midi out goes via another midi interface back into the computer to play VST’s or alternatively a hardware module.

I believe this is why the roland gear has this so-called “advanced driver”.

Good idea, that would’t work for my drumkit unfortunately, but for the Blofeld it should. Will have a look at my options with my different MIDI interfaces. Thanks.