Locating VST instruments in Dorico

Hi, I just bought Dorico 5 Pro and besides that i am not capable of getting it to sound (even after watching the video on that topic, i have a problem with the `VST instruments. I have BBC Symphony Orchestra Core but Dorico does not show it in the list. Even when I have loaded Halion and press the “E” nothing happens. Is there not a locate function to find where the VST instruments are? Please help. Thank you in advance.
Dorico Diagnostics.zip (625,2 KB)
you in advance.

Welcome to the forum @mflobenstein .

There is something strange in your setup. We have a VST3 plug-in scanner that loads every VST3 plug-in to do some basic test with it. Plug-ins that don’t fulfill the criteria get sorted out and put onto a blacklist.
Now, that scanner finds /Library/Audio/Plug-Ins/VST3/Vienna Instruments.vst3 and detects that it is only for Intel CPUs only but not for the Apple Siliccon you have. The weird thing is, the scanner recurses and scans that Vienna plug-in over and over. Thus the blacklist grows longer and longer but only ever with that very same item.
To break through this dilemma please try to move /Library/Audio/Plug-Ins/VST3/Vienna Instruments.vst3 temporarily out to for example the desktop. Will then other plug-ins get detected?
Or you could try running Dorico in Rosetta mode. Do you know how to do that?

Hi Ulf, Thank you very much for your swift reply. the solution with moving the files did not work. Other plugins were not detected. I do not know how to run Dorico in Rosetta mode…

To run in Rosetta mode, go in Finder to the Dorico application, do a right click on it and click on Get Info from the pop-up menu. In the info window that appears is somewhere an option saying something about Rosetta. Tick that, close the info window and then start Dorico as usual.
If still a problem, please send a fresh diagnostics report.

Hi Ulf,

I ran Dorico in Rosetta mode and now it found all my plugins. So that worked. I am happy with that!. However Halion Sonic and The Olympus Choir still do not work and are not visible…
Dorico Diagnostics.zip (588,0 KB)

Please send a new diagnostics report. Thanks

Dorico Diagnostics.zip (588,0 KB)

Thanks for the data.
That is interesting, now it finds all your VST2 plug-ins, but no VST3 plugs at all.
See, HALion Sonic comes only as VST3 plug. And Olympus Choir is just a sound library with out own player, so you load the Olympus sounds normally into HALion Sonic.
But I’m irritated that no VST3 plugs get detected with you.
Did you move the whole VST3 folder away from /Library/Audio/Plug-Ins/VST3 or just the Vienna Instrument. If you go with Finder to /Library/Audio/Plug-Ins/VST3 what is listed there? Maybe take a screenshot.

Thanks very much, but I’m still puzzled. The Steinberg folder that you highlighted there, what is the complete path to it, I mean the full path from the root of your hard-drive. Thanks

You’ve got aliases to other VST folders. What’s going on there? That’s not a ‘recursive’ alias to itself, is it?

Yes, that’s a good point @benwiggy. That would explain the vst3scanner getting “confused” like it did in the native mode.

So what do you suggest I should do now?

Don’t know, yet. In that folder that you made the screenshot of, there are two subfolders: VST and VST3. Are they really folders or just symbolic links? If so, where do they link to? Or if they are normal folders, what is inside of them?

The “VST” and “VST3” look like symbolic links to me, as they have the little arrow inside the folder icon (in the bottom left corner).

Yes they are, I deleted them and now I, can find the Halion. I noticed something strand, The files for olympus are located in my downloadsfolder…Maybe If I put them in another folder it might just work?

Finally it is working, I found the olympus in the Halion Sonic, so now can i continue learning the program. Thank you for all your help! removing the links did really the trick!

they were just links with nothing in them

Hi @mflobenstein , great to hear that it is now working for you.
You can even consider going back and switching Rosetta off again. You might just need to get an update for Vienna so that it is Apple Silicon compatible.

And one more important thing: You said you found Olympus Choir sounds in your downloads folder. That is not bad as such , but you need to check if they were installed to that location. Please start the Steinberg Library Manager (gets installed along with Dorico). There you find all the HALion sound libraries listed. On the right side are for each library 3 buttons. Click on the Details button and check the installation path for each library.
If any of them shows a path into your Downloads folder, then change that using the Move button. In theory you can move it anywhere you like, but I propose to move it to the default location that is /Library/Application Support/Steinberg/Contents/VST Sound
After that you are safe to use the HALion sound libraries.

1 Like