Lock to duration not working in 1.0.20?

I’ve just updated Dorico and I can’t get Lock to Duration to work anymore. Is there a way that it should be used that means I’m now having this trouble, because moving the caret to a note, pressing L and then inputting note ignores the duration and deselects the tool.

Obviously since posting this it typically started to work, and I can’t replicate it!

I believe there may be a problem whereby clicking the button with the mouse appears to switch on the option but does not actually cause it to take effect, which will be fixed in the next update. Using the L shortcut should work in all circumstances in the meantime.