Locking Systems

How does one lock the distances between the staves of systems and the distance between systems so that other edits don’t affect these distances? When I adjust a high upward stem in the lower staff of a piano part, the upper staff moves downward with each adjustment, which is undesired. Earlier today the systems jumped further or closer to each other with each re-spacing of the notes on a single system, and the systems were not even close to each other.

I have all signposts visible, but no lock icon is visible to me after I select a note on a system and depress “lock system”, and the unwanted behavior remains the same. What am I missing? I can find nothing specific in the documentation.

Try this: https://www.steinberg.net/forums/viewtopic.php?t=132995

“Lock System” doesn’t have anything to do with staff spacing - it adds Frame Breaks and System Breaks in order that the bars on each system aren’t allowed to shift onto different systems.

I’m afraid you probably need to rethink your workflow. Minute staff spacing adjustments really need to be pretty much the last thing you tidy up manually, after everything else is fixed.

Two things that might help:

  1. For many objects you can turn off “Avoid collisions” in the properties panel (by which I mean: turn ON the switch and then UNTICK the box).
  2. There’s a known bug that seems to affect tempo markings and rehearsal marks in particular. If you have two objects near each other, they sometimes magnetically repel each other and that can have a knock on effect on staff spacing on surrounding pages. As I said, it’s a bug! The easiest fix is to delete one of the objects and place it again.

Thanks, dankreider and pianoleo. I’m sorry to hear that one can’t turn off the automatic spacing behavior when desired. That capability would be very helpful, but probably terribly difficult to program. I couldn’t find any objects that had an Avoid Collisions property in the Engraving panel. I read something about collision avoidance for slurs in the documentation but that didn’t seem to pertain.

Yes, Dorico definitely requires some workflow rethinking, which I will do after I am more at home with the program.

You can turn it off, but globally, in Layout Options > Vertical spacing. That way, the spacing will only obey settings for the ideal gaps between staves.