Logical Editor Question

Hello, I have been trying to get 2 functions going for a while and couldn’t figure out so reaching out for some help!

  1. How would I go about setting up something to delete just the first bar of a part?

I like to start recording one bar before a section, and always end up with empty first bar. I have been deleting or resizing the first bar manually and trying to see if I can make it quicker.

  1. Is it possible to just quantize the first note of a part?

When I cut the first bar, the first note gets missing many times, and I quantize just the first note to avoid that when I don’t want the whole part quantized.

Any help will be appreciated!
Thanks in advance.


Hi Brandon,

I will have a look on these functionc later on. But, I think, I have a more common solution for you even without the Logical Editor.

  1. Why do you need to delete it? You don’t save the space on your HDD. The file will be the same. Do you want just to cut it for better edditing later on? You could use Pre-roll, if you want to hear one bar before recording.

  2. Again the same question: Why do you cut it? You recorded the note a little earlier, so probably it should be earlier, or not?

Hello, thanks for the reply.

Yes I do it for better editing and organization. It makes duplicating parts easy and neat.
I don’t use pre-roll because I like to hear parts before recording maybe not just one bar, sometimes 2 bars or whole previous section.

Regarding the first notes. if the note is just slightly earlier than cut off of a bar, it will make it disappear.
So I always have to hard quantize the first note and cut the first bar off. That steps are kind of tedious so I want to make a macro to “Quantize the first note” and “Cut first bar”

Hope that makes better sense. :slight_smile:


The Macro (not Logical Editor) could be this:

  • Edit > Open Key Editor
  • Edit > Select All
  • Navigate > Left
  • Navigate > Right [-> only the very first MIDI Note is selected, now]
  • Quantize
  • Edit > Open/Close Editor

I hope, this will work for your 2nd scenario.

Thank you that will help a lot!
Any idea with the first scenario?


I tried some ideas with the Logical Editor for the 1st scenario, but the Lenght command always change the length of the right border. I could prepare a Macro again, but it would be little risky from my point of view. Something like:
Precondition: The event is selected.

  • Go to Selection [The cursor jumps, in general, I don’t like, when I change the cursor position while doing Macro]
  • Nudge right [The expectation is, the grid is always set to 1 bar].
  • Split at Cursor
  • Left [The left event of the Split is selected]
  • Delete

Hey I actually achieved scenario 1 applying your suggestion!
This is what I did. I actually didn’t have to use Logical Editor at all.

Locate to selection - Step Cursor Bar - Split At Cursor - Navigate Left - Delete

But the solution you suggested for Scenario 2 only works when if the part is monophonic. If there more than one note, it would only select one. Can you think of any work around for this?

Thanks for all the help!!


For the 2nd scenario, the Logical Editor would help. The problem is, the Logical Editor preset cannot be used with Macros.

But the idea of the Logical Edito is:
Filter Target:
( Type Is | Equal | Note | And
Position | Inside Bar Range | 1900 | 1920 [it meens, ale MIDI notes, which are in the last 20 ticks, will be affected; maybe, you have to change this value, of Parameter 1 if your notes are more inaccurated]

Action Target:

  • Keep it empty


  • Select.

Now all MIDI Notes, which are very close to the 1st beat of every single bar are selected. Be carefull, all bars are affected, not just the very 1st one. Store this as your Logical Editor Preset (“Select all Notes close to 1st beat from left”)

Once you have these MIDI notes selected, you can quantize them. So I would expect something like:

  • Open Key Editor
  • Apply Logical Editor preset “Select all Notes close to 1st beat from left”
  • Quantize
  • Close Editor.

Be aware, there is a bug in Cubase, I just discovered…

The very 1st Logical Editor user preset is not visible in the Key Commands. So you have to create at least 2 user presets. Name the 1st one like “_”, to be the 1st one, which is not visible in the Key Commands.

Hmm… I somehow do not see filter target “Type”
I only see Media, Container, Name, Position, Length, Property.

About that bug, I found out that if you restart the cubase it shows up in the list.
And I was able to make a macro combining process logical editor and commands so I think as long as I can get it working, it shouldn’t be a problem.

These are commands of Project Logical Editor. But I made the “code” in Logical Editor, which you can find under MIDI menu.

Good to know, thanks.

Oh I see what you mean by Logical Editor cannot be used with Macro.
I did make a lot improvement so thanks for all the help Marin!