LOGICAL PRESET ISSUE[BUG CONFIRMED]

When highlighting a set of MIDI notes to change to double time in particular, I used the logical preset resulting in notes moved to a random bar, with most notes starting at the same point.

I have provided 2 jpg files showing the highlighted MIDI notes I wanted to change to double time along with the result.
I have no idea as to how this could be happening. I did indeed trash my preferences afterwards and repeated the process and the same result came about.

I also tried starting a new project and re-recorded the notes from my MIDI keyboard and the same error happened.

If it matters, I use the Yamaha portatone WDM USB MIDI driver in order to play my MIDI keyboard into Cubase 6.


This is a really strange and annoying problem, please address this issue ASAP, Steinberg.

Thanks,
Daniel.
midi2.jpg
midi1.JPG

I can confirm (although, when I first tried, using just a few simple short notes it worked o.k… So I set up a MIDI Part that was more similar to yours, and, indeed the result was wrong). It is working fine in Cubase 5.5.

Thanks for testing. I was dreading it being my MIDI setup. Please Steinberg look into this!!!

Can anyone at Steinberg give an update into this issue, it is affecting my workflow… :frowning:

EDIT: Here is the file below shown from the previous attachments,
rnb-01.cpr (314 KB)

I couldn’t reproduce in Cubase 6.0.1.
The logical preset “double tempo” divides length and position of the notes by two. Could you attach a cpr file to one of your posts in which there is midi data where this calculation does not occur correctly?

Gr,
JHP

Regarding your cpr:
On which MIDI data in the cpr does the “double tempo” divide position and length by two calculation not work?
Could you give me precise repro instructions?

Gr,
JHP

Sorry about that, the MIDI data entitled MIDI 03 was the issue. On closer inspection however, using the logical preset on the cpr file I’ve sent does actually work correctly :open_mouth: . What is strange is that, on the 1st saved version of the file it still doesn’t work. I’m sorry to have wasted your time checking the wrong file. I have provided the 1st saved version of the project with the actual error

In terms of the repro:

I double clicked on the event MIDI 03 and the key editor showed on the display.
I highlighted the notes recorded and clicked on the MIDI submenu to find logical presets and proceeded to click on the double tempo option.

It is quite weird as it seemed to be the only MIDI part that doesn’t work correctly for me. I did try the other MIDI parts and the function does work correctly.

Thanks for your time.
rnb.cpr (313 KB)

Hi Daniel,
I tried something with your .cpr, which worked (though I’m not sure what caused it to do so :confused: :slight_smile: )…
The problem is with the MIDI Part on the lower lane, right? I split the Part, so that there were no empty bars before the first note. The Logical Preset then worked correctly.
Now, here’s the fun bit :stuck_out_tongue:
I used Undo, to undo the Logical Preset, then glued the Part that I had split back to it. I tried the Logical Preset once again, and it worked correctly again!
I haven’t seen the “logic” there, but it seems to be… cut the empty space to the left, then glue it back together again, then use the Logical Preset.

Thanks for that, guess I have to be more efficient in the way I work. :blush: Ill change the title now thanks again vic_france and JHP for looking into it.

A workaround would be to mute the events above and below the problematic event and then to execute the “MIDI–> Merge MIDI in Loop” command for it. With this command changes that you have made in the inspector or the infoline will be set back and written into the actual midi data stream. After this the logical editor presets will function as expected

Bug Report:
Problem with events that have a negative offset and the logical editor.

Repro:

  • Record some MIDI into an event.
  • In the infoline of the event set a negative offset, let’s say “- 4.00.00.000”
  • Execute the logical preset “double tempo” twice for this event

Problem:
Here is a gif that illustrates the problem:
LogicalEditorDoubleTempoBug.gif
The selected notes will approximate a certain position on the grid and the actual incorporate offset–> divide length and position by two calculations does not create expected results for us users.

Workaround:

  1. First “Merge MIDI in Loop” then execute logical editor preset
    Edit:
  2. Make a cut on the event with the offest and the offest will be removed from the infoline and overtaken in the actual midi data.

Status, Comments
Confirmed, Cubase 6.0.1 Build 270
Original report topic
(28530)

Gr,
JHP

To double tempo MIDI I also like to use the "Object Selection"and “Sizing Applies” time stretch tool with appropriate quantize settings.

I always would use the presets double tempo and half tempo on entire events from the arranger page and not on a note selection within an event. Just cut the event and then execute the preset. This gives you a better overview and you do not have notes actually jumping back in the arrangement if you have note exactly at an event start point.

We cross posted.
I still would call this unexpected behavior and reported it as a bug now.
The thing is as soon as the cut is made that vic was talking about the offset seems to be overtaken from the info line into the midi data stream. I will add this to the workaround.

We now know the cause and the workaround to this problem.
Thanks DanielAyo and vic_france!

Gr,
JHP