Logidy foot switch controlling CB7 transport ?

I just got the 3 button Logidy foot switch to control CB7 record, play, and stop transport functions.

Could somebody please help me get it operational.

Do I have to create a Generic Remote in Cubase ? Do I use MMC ? And what CC numbers or
whatever do I assign to each of the switches in the Logidy ? Where in the Cubase docs does
it show what control change numbers map to the transport functions that I should program
into the Logidy pedal ?

Any help would be much appreciated.


Provided that the footswitch (UMI3, I guess ?) is already installed with its software, I would do the following :

  1. Configure your three footswitch buttons with three different CC number in the UMI3 setup panel. I use the following ones with my 2 remote controllers installed :
    Record : CC 119
    Play : CC 118
    Stop : CC 117
    But any other values should theorically work. Try to not use CC numbers used as MIDI generic controls, though. In other words, avoid ones such as CC7 (volume), CC1 (modulation), CC64 (sustain), and so on…

  2. Create a new Generic Remote device in the ‘Device setup…’ window. Just keep only three controls (lines) either in the top and the bottom panel. Then…

In the top panel , enter the following values :
Record / Controller / 1 / / 127 / R,
Play / Controller / 1 / / 127 / R,
Stop / Controller / 1 / / 127 / R,
If you want to use a MIDI channel different than 1, then change accordingly the third value of each line.

In the bottom panel :
Record / Command / Transport / Record / P
Play / Command / Transport / Start / P
Stop / Command / Transport / Stop / P

[EDIT : should have mentioned this first ! Set also the ‘MIDI Input’ entry (top of the window) to the correct port. I don’t know what is the MIDI/Audio device that allows you to use MIDI incoming data, but you should have at least one MIDI port available in here. Set also the ‘MIDI Output’ one to ‘Not connected’.]

Do not forget to export to an .xml file of your Generic Remote device just defined, with the ‘Export’ button. This is necessary to make Cubase retrieve it for future sessions. Once done, your footswitch should work as expected…

Many, many thanks Cubic13 for the quick, clear and thorough response. I spent hours trying to find
this information to no avail. Can’t wait to try it out tonight. The Logidy pedal (yes, its the UMI3- the
only one they make I think) appears to be solid and a good choice. But their website support is
pathetic with no forum and very lousy docs so it was no help to RTFM. And I wish Cubase in their
Remote Control docs had a few examples.

Anyway, I digress. Again, many thanks for taking the time. I hope this helps some more frustrated

I expect I’ll be back when I try to utilize their paging and multiple commands per button function,
which also has pathetic instructions.


Maybe it won’t be necessary… You can easily do this in your Generic remote definition, by using the bank feature of the ‘Device setup’ window.

On the side of the bottom panel, you have a selector with four different predefined banks available. This means that, after having set the controls available with their CC number, MIDI channel, etc. in the top panel, you have already four combinations of commands at your disposal. From this, you can add, delete, rename as many combinations of commands as you want by defining them in the bottom panel, each combination being a bank, and using the three dedicated buttons under the bank selector.

Don’t hesitate to use them in order to have your generic remote definition set exactly as you need. All the banks defined here will be saved in the generic remote definition .xml file. Again, just don’t forget to save it each time you edit something.

After, it’s just a matter of selecting the needed bank, using the selector in the little window available with the ‘Devices/Generic remote’ menu option, for which you can set a key command for a quicker access (‘Devices’ category).

Heeeeee’s baaaaaaack. Now I want to become a Logidy Jedi Master.

Now I’m trying to make a single press and release action on ONE Logidy button do TWO things, e.g. start Record when the button is depressed and Stop Record when the SAME button is released, using the “2.5 Release Message Function” in the manual.

My understanding is that you turn the Release Message Function to “ON” by clicking on and turning the “Release Msg” button at the top of the desired “button sequencer” to “ON” or red. DONE.

You then insert the CC # for the SECOND desired action in the “V2” field of that same button sequencer, which is supposed to occur when you RELEASE the same button. On the same line as the line that has the RECORD CC 119 in the V1 spot.

So I inserted the “Stop” CC 117 in the V2 field. The V1 field still has the “RECORD” CC 119 in the V1
field. DONE

So presumably depressing the first switch sends a CC 119 “RECORD” command to Cubase and releasing the same switch sends a CC 117 “STOP” command, thereby starting and stopping the record function with a single press and release action of the same first Logidy button (the one that was succesfully putting Cubase into the RECORD mode).

Note that I changed nothing in the Generic Remote of Cubase which was already set up per your instructions and worked fine as I reported in the prior scenario where first button was Record, second button was Play, and third button was Stop. I simply now want to record as long as the first switch is depressed and Stop recording when the same first switch is released.

And I sent the new Logidy setup to Logidy and saved it.

Only problem is it doesn’t friggin’ work as desired. Pressing the first button still puts Cubase into Record mode
but releasing it does nothing and I have to stop Record with the third button.

What am I doing wrong ? Grrrrrrrrrr…

Bungling Bob

What I put in bold is a part of the problem, IMO : here, using the ‘Record’ of my MPD-32 controller acts exactly as clicking the Cubase transport ‘Record’ button ; it starts the timeline and the recording then interrupts only the recording without stopping the timeline course, all this with the same CC number. Using a CC117 (stop) makes both the timeline and the recording stop. So, I advice you first to set the same CC number for BOTH V1 and V2 fields.

Beside this, I could get the same behavior as what you are, I guess, expecting, using a spare button on my MPD-32 : I had to set it to ‘CC transmit’ ch.1, CC 119 and, which is important : ‘Momentary’, which means that depressing the button transmits a 127 message and when releasing it, a 0 one, at the opposite of the other ‘Toggle’ mode which sends first 127 when depressing it and 0 when depressing it again : the release actions aren’t taken into account.

The result is that I can start both the recording and the timeline, then with further depressing/releasing actions, interrupt/resume the recording, the timeline always continuing its course. Guess that you’ll have to configure on your UMI3 the behavior of the footswitches accordingly, if possible. Seeing the setup panel in the UMI3 manual, I think you should try to play on the footswitch configuration (message type), the release message function and the sequence length.

I also try to modify things in the bottom panel of the ‘Device setup…’ window :

  1. I tried to modify the cammand to the following : Record / Transport / Device / Record. No change and the other options, record related, are of no use in this case.
  2. I tried to modify the flags, using ‘Transport’ instead of ‘Command’ in the ‘Device’ column, this allowing to choose between P, T or both of them. No changes in the behavior either.

To sum it up, I think that all depends of your UMI3 and its eventual ability for the footswitches to be used as my spare button in the ‘Momentary’ mode. At the end, I’m almost sure that you’ll find the good settings after experimenting.

EDIT : CORRECTION ! Reading more cautiously your manual, I think that you should forget what I wrote above in my first paragraph and try the following :

  • Set the ‘Release message’ function to ON.
  • Set the sequencer length/step to 1.
  • Set the message sent to : ‘Event type’ to ‘Start, stop, continue (real time messages)’ / MIDI channel to the choosed one / V1 to 119 and V2 to 127. If I’m understanding well, using the ‘Release message’ makes the release of the footswitch to send exactly the same messsage but with a 0 value, instead of 127, which should interrupt the recording. I don’t think it will stop also the timeline, but at least, you should be able to use the footswitch exactly as the Cubase transport ‘Record’ button with depress/release cycles. Worth checking…

Thanks again ! Been outta town and haven’t had a chance to try your suggestion but will tonight.
And BTW I heard back from Logidy tech support the following:

“The release message is the same as the “push down” message except for the value of the V2 field which is forced to 0.” This predicts the behavior of the product accurately and provides a explanation for what you are experiencing. As to whether you might be able to use this information to achieve the desired outcome depends on Cubase’s ability to discriminate messages from the content of the 3rd MIDI byte (we call it V2). Hopefully you will find the answer to that in Cubase’s documentation.

So I now at least understand that the purpose of the “Release Message” is to override or drive any non-zero setting you have put in for V2 to zero when the Release Message is “ON” so that you’ve effectively created a midi note on-off message. I had erroneously thought depressing the switch would send the first midi message type byte (like “Note ON”) along with the second byte (V1) (e.g. “ON” or “RECORD” CC 119") and releasing the switch would send the same message type byte but this time with V2 (e.g. “OFF” or "STOP RECORD CC 117). I did not understand why you would want to override a non-zero value for V2 with a “0” rather than just putting the “0” in for V2 in the first place, so I assumed it was some sort of typo in the manual.

BTW Logidy took exception to my observation that their documentation was insufficient and I was apparently the first person in 4 years to make note of this. I guess I’m just some weirdo terminally stupid idiot.

I have my doubts now that I can put Cubase into Record with a button push and then Stop with release of that same button as I had originally wanted. But I certainly can make it toggle between Record and Stop with sequential pushes of one button which I suppose is just as good for my purposes.

I do however want to rewind and redo a take, e.g. first button causes Start Record on first press and Stop Record on second press with no rewind, and second button causes a rewind to the beginning of the take. Any idea what the settings are for a rewind ? Or is it back to the Cubase manual for me. Surely you don’t have to set
the Locaters every time to get a rewind back to the beginning of your last take.

Well, I’m not sure about whether you want just to move back to the start of your recording or if you want to move back and start recording again at once. So, just keeping the first button as it is and setting the left locator where the record should start…

  • In the first case, For the second button, set its command line as :
    Record / Command / Transport / To left locator

  • In the second one, things get a little more complicated and you have to set a macro :
    a) Open the ‘Key commands’ window (‘File / Key commands’ menu option),
    b) Click on the ‘Show macros’ button,
    c) Click on the ‘New macro’ one and name it, i.e. ‘Backward-Record’,
    d) In the top panel, select the ‘Transport / To left locator’ command,
    e) Click on the ‘Add command’ button,
    f) In the top panel, select the ‘Transport / Record’ command,
    g) Click on the ‘Add command’ button,
    Macro setted. Now go in the ‘Device setup…’ window and, for your second button command line, set it as follows :
    BackwardRecord / Command / Macro / Backward-Record.
    Actually, you’ll have first to rename its corresponding line in the top panel, as ‘BackwardRecord’. You’ll have also to set it to stop the recording at the next depressing, because the first button doesn’t allow you to do so at first if you keep it as it is.

Works here with my MPD-32, but be sure to set precisely the ‘Audio’/‘MIDI record mode’ settings in the left of the transport panel according to how you want to manage several takes. Use also the lanes display : believe me, it helps…

You could also use a marker, in which case, you’ll have to replace in both cases any ‘Transport / To left locator’ command by a ‘Transport / To marker 1’ one.

I should have been more clear.

With the recorder OFF I noodle at the keyboard until I find a few measures I like. Then I want to hit
RECORD with my foot and capture what I just did.

If, in recording, I blew it, I want to just rewind to where my last RECORD effort had started (avoiding having to place locaters) and pause or stop. Then noodle and practice some more, and then hit RECORD again and capture it recording over the most immediate prior take that had the mistakes, hopefully correctly playing and recording it this time, and the STOP.

And then go on to a next section the same way: noddle and practice, RECORD it, STOP, if its okay then
go on to the next section, if it isn’t, then rewind to where that most recent RECORD had started and
pause while I practice again, then RECORD over it.

So what I will have is a series of 2-4 measure takes that are all correct “keepers”. This saves me time
from having to go back through all the series of 2-4 measures I had recorded (some with mistakes and some that are keepers), and recognize and delete the only the ones that were screwed up.

And the need for doing the feet to do this is if I lift my hands to punch record- even if I used a keyswitch- I have lost the tactile memory of going from one chord voicing to another. I’ve wasted lots of time after I find a sequence I like being distrupted with the mechanics of hand controlled transport commands, and sometimes have lost chord voicings forever or had to spend alot of time trying to find them again. Maybe unnecessary with a better ear or more ear training but…

Excuse me if this is way off the mark – I too have the excellent UMI-3 which is what attracted my attention to this thread in the first place – but I think you may be going to an awful lot of trouble unnecessarily. Have a look at the “Retrospective Record” feature (details are in the Operation Manual, on page 128 in my version).

I was about to suggest the same thing. But maybe there is still another solution, setting the ‘Release message’ to OFF. It would look like this, involving three footswitches :

Footswitch 1 :
Command / Macro / RecordWithMarker1
-> call of a macro which would have the following commands :
Transport / Set Marker 1
Transport / Record

Footswitch 2 :
Command / Transport / Stop

Footswitch 3 :
Command / Transport / To Marker 1

Maybe I’m not understanding what’s asked for here, but no one has mentioned the “return to start position” command.

Retrospective record does seem to fit the bill nicely too.

Indeed… :blush:

Completely forgot this one, as I never used it as a remote controlled command. Just checked and it works perfectly. So, apologizes and correction :

Footwsitch 1 : Command / Transport / Record

Footswitch 2 : Command / Transport / Stop

Footswitch 3 : Command / Transport / Return to Start Position

Much more simple, I admit…

OTOH, using the retrospective record is more difficult if other tracks were previously recorded, IMO. We have to cut precisely the take choosed and adjust it, time related, to what is already existing. I think that using the lanes are more accurate for what bcarwell needs.

Actually, I mainly use the retrospective record at the very beginning of a project as an initial take to set the general frame of what will follow. It’s already priceless as such.