Long held vestigial notes in MIDI export

I’m working on a huge orchestral score in Dorico, and decided to export a MIDI file so I could play with it in Digital Performer.

Once Digital Performer opened the MIDI file, I noticed the woodwinds, brass, and percussion made it across as expected, but the strings look like this, with a second track for each instrument:

Screenshot 2023-05-04 at 9.18.33 PM

But the problem is that there are very long notes in those second tracks that don’t belong there. If I open this in Digital Performer’s notation editor, I see this:

Those super-long notes in the 3rd, 6th, and 9th staves don’t exist. They’re not supposed to be there. They’re not there in Dorico. I’m wondering how they appeared.

As I glance through the rest of the MIDI file, I’m seeing a lot of these extra, super-long notes there that aren’t supposed to be there.

What are they, and how do I fix them?

UPDATE: Woodwinds don’t have super-long notes like this, but they do have lots of very low C0 and C#0 quarter notes that don’t exist in the score. Similar problem. Are these some kind of playing technique triggers or something like that? Maybe some way Dorico is translating heavy accents or something?

I also have had this same thing happen, specifically when importing strings, on that same note (low F sharp/G flat).

From memory, I think the fix is as follows:

After having clicked on Open or Import File and then selecting the file, the MIDI Import Options window will (should) open. Click on Import Options at the bottom of that window. There should be an option to Filter out key switches outside a certain range. Enable that and click OK.

1 Like

Thanks for the reply. It’s a good theory, and yes I could manually remove these MIDI notes, but across a very large orchestral composition, it’s problematic to do it at the DAW end, because I can’t be sure whether they are vestigial key switches, or real notes in the score, and I don’t want to delete the latter.

It looks like most of my crazy notes are at C0 and around there - my bass instruments (bassoon, contrabassoon, double bass) sometimes play in that range. So I can’t just blanket-delete all C0’s.

I’m hoping there’s something on the Dorico side of things that can filter this out before exporting…?


It sounds like your MIDI Import/Export requirements are not as simple as mine.

Another user might have some ideas on how to achieve what you have described.

Those notes are all key switches, so they’re certainly not vestigial. When you export MIDI from Dorico, it exports exactly the same music that it plays back. If key switches are used during playback, then key switches will appear in the exported MIDI.

If you want to ensure that your exported MIDI data contains only notes, the best thing to do is apply the HSSE (SE) playback template before you export your file, as this playback template uses only simple GM-style sounds that don’t cause any key switches or MIDI CC values to be played back. If you’ve tweaked the playback of your project, I suggest you change the playback template on a copy of the project rather than on your original, as changing playback template is not undoable.

Thank you Daniel. I’m not sure how those key switches got there, but re-applying the HSSE (SE) made them go away. Thanks for the solution. (I haven’t done any tweaks to playback so I’m not concerned with losing things there.)

I think Daniel explained it very clearly. If you use the HSSE+HSO(Pro) playback template you will see in the Endpoint setup that instruments are using HSO xxx expression maps, which use key switches to change articulations. Therefore those key switches will be included in the MIDI export. By contrast the HSSE(SE) endpoint shows that the CC11 Dynamics expression map is used. This does not add any key switches.