Long Save Times 5 instances of Kontakt

Hey all,


I have a template I’m creating. Right now it includes 5 ‘purged’ instances of Kontakt. Kontakt 1 has Instrument Banks of Short Strings, K2 has Instrument Banks of Long Strings, K3 Ensemble Strings, K4 Winds, K5 is empty right now.

I’ve purged all the samples via Kontakt’s purge command. However, without any data in the actual sequence the save is already taking about 5-6 seconds. Is this normal?

PS - I’m using 8.05 on a Mac with OS 10.9.5 - I would use vienna, but am experiencing the muting/noise issues that haven’t yet been fixed.

I don’t have that issue on Windows 8.1, Cubase 8.05.

How many samples you are using will not affect save time - unless you are tight on memory and the harddisk is busy and you’re saving whilst playing the project at the same time. Other than that the difference will be nil.

Very odd. Empty seq saves very quickly.

Every Instance of Kontakt can add a 1/2 to 1 second to the save time for me.

Wow. If that’s true, that’s a problem for me. Gonna have to go back to 7.5 and load everything into Vienna.

same issue in 7.5

There are some information on the net how to best disc manange Kontakt. Look them up and see if that helps.

I’m not sure what you mean. Even if the Kontakts are purged with no samples loaded, or sometimes completely empty the problem doesn’t occur. I’m gonna try an experiment later today with logic to see if the problem is Kontakt or Cubase related.

I only have the long save times issue when using EWQL PLAY, everything else works fine for me. Cubase 8.05 with 2013 Mac Pro Quad here.

To both of the last OPs on this thread: Pls Complete Your profile so Your system will be displayed. It makes us who try to help you give better advice as some question are environment related.

The Kontakt problem. I have thoroughly watched the tutorials on how to set up Kontakt to avoid:
Long Load time
CPU strain
I have installed accordingly (or as close as I could get). I have no trouble what so ever With Kontakt.
Most People complaining about Kontakt and Omnisphere does not know that some simple steps will get a much better performance.

And yes, Logic and Cubase behave differently when it comes to Kontakt. Logic handles Kontakt better. It has been explained to me why, but I am not able to reproduce the information. It is there on the net if you are interested. That was at least Logic 9. Do not know if the same thin applies to Logic X.

It’s a 2012 mac pro with 64g of ram with 11g of drives for samples and 1 512ssd for strings and brass streaming.

This isn’t an “issue” - a complex and very customisable VST such as Kontact will require a fair amount of data to express its current status. Each instance will also have routing options associated with it meaning mixer configurations will have to be accommodated. As I said before - the number of samples isn’t the issue. However, if the delay caused by loading or saving what is an incredibly complex and versatile instrument is too much to bare - then perhaps you’re in the wrong game or have unreasonable expectations. The first computer I programmed required you to enter machine code (not assembler!) in a step by step basis by flicking switches - it might take an hour to import enough code to make a light blink. FFS cut these guys some slack. If you have to wait 5 seconds to save the kind of sound it would have taken Kraftwerk 6 months to code - think yourself lucky! Rant over.

What are you talking about? It absolutely is an issue.

I tried the same setup with Logic and Abelton and the issue doesn’t exist. That means there’s something about Cubase that creates the issue. For better or worse, I’m faster with cubase and would rather not switch. But if workflow is interrupted by that much, it makes the working environment untenable and the switch will have to be made.

I’m glad your Moog and Atari took forever to do menial stuff, but we live now, and my projects are time and workflow sensitive, so please forgive me for wanting things for going well. The Turing machine took forever too and its still ok to complain when your computer runs slow. Its like telling someone that they can’t complain that their car goes slowly up a hill because at one point people had to do it on the backs of mules.

I come here and ask questions not to get flamed because a sequencer is working better than Notator did back in the 80’s, but instead to find solutions. If you don’t have one, fine, but don’t come in here and decide that because back in the day you had to walk up hill in the snow both ways that we should all want to work slowly.

I don’t think it’s too much to ask that a sequencer not take inordinately long to save a sequence. I load very large palettes and with auto save is on, workflow is very horribly interrupted when it autosaves. So now I have the option of turning autosaves off, or dealing with painfully long saves every 10 minutes. Neither of these options is acceptable.

The other solution is to keep the Kontakts loaded in Vienna, but that is unworkable due to the issues Cubase 8 has with Vienna.

Cubase might have much more internal complexity around each VST instance - hence it takes longer to save - if it’s the way the product is coded - you win some, you lose some. Have you tried using your SSD to store your current project? Does that help? If so perhaps you could consider a separate cheapo 100Gb SSD just to store the current project you’re working on.

I just wanna say that I have a similar system to the OP, and that this issue is a HUGE PITA for me and my workflow. I have a frequent autosave set and nothing disrupts the flow more then having to sit 5-8 seconds every five menutes and watch the beachball spin.

It’s really, really, really annoying. Not to mention session sizes are now HUGE - I’m at 42 mb per session. My session backups end up taking gigabytes of storage space.

As trivial as this may seem, it really is making me consider switching back to Logic again. It’s that annoying.

I would totally switch to logic if I was quicker at it as the long saves during work really does disrupt creative flow.

My solution thus far has been to offload all the Kontakts to Vienna on the same box. It’s not ideal, but it works.

Be warned, this won’t work well with 8 as 8 currently has drop out and digital noise issues with Vienna.

Is there any word if Vienna (or Steinberg) are working on these issues?

not exactly.

http://www.steinberg.net/forums/viewtopic.php?f=231&t=70250

Not sure that adds up. I have between 40 and 60 Kontakt instances in each of my projects (native, not using VE Pro) and the projects save in 3-5 seconds total.