Longstanding bug with Elastic Pitch : big clicks

Hi,

I jumped last year into the Nuendo environment and absolutely love it. However I recall from about 7-8 years ago a client coming with his computer and Cubase sessions full of clicks that were not visible in the audio : they were caused by Elastic Pitch. Switching to Standard-Mix fixes it for audio warp.

Fast forward today : I received a session from a client to mix, and I heard a few clicks that I couldn’t see anywhere, no edits, cuts or fades. Turns out it is still the same bug.

Any fix would be appreciated,

Best

N

To pitch shift an entire project is a very advanced and resource intensive process.
Clicks are mostly a sign for the audio engine is beyond its limits.

I wasn’t talking about an entire project, but on a few events. There are clicks in some of them with Elastique Pro, repeatedly, only they aren’t visible and it is not a cpu/buffer size/setting issue.

What is Elastique Pro?

Oh, I found out it’s a time stretch algorithm. Never realized it is spelled like that.

My bad it is “Elastic Pitch” and then the “Pro” and other suffixes.

Even with medium/high buffer sizes in low cpu projects those digital clicks happen on short events.

Audio engine drop-outs are caused through different things. CPU stress is just one possible reason.

And you didn’t mention if you are on Win or Mac, which hardware you are using, and so on.

That does not explain why a simple event of audio using the Audiowarp function creates an identical and systematic click at the same point in time, while switching the warping algorithm removes the audible click.

As I said this happens regardless of buffer setting, different cpu settings of ASIO guard etc… and on different systems, Windows or Mac.

I have no system issues, running mixing sessions on Nuendo, Logic Pro, Pro Tools as well as heavy Dolby Atmos sessions.

This is a software error, hence the “bug report” in my subject line.

MacBook M1 Max / 16GB RAM /SSD’s only/Metric Halo ULN-8 converters

That’s the reason, why there are different algorithms.
I still don’t see a bug.
And btw, elastique audio is a 3rd party algorithm.

1 Like

You could

  1. Render in place
  2. turn on and off click removal to help fix it just in that one location and then Render it in place again.

I know about those limitations.
I use Reaper, that uses Elastique, for a long time both on Windows and Mac and have no audible clicks.

Yes, there are other artefacts depending on the source/algorithm/intensity of the stretching, on all systems : warbling, phasing, stuttering, spectral distortion etc…

Same for Ableton and ProTools : no clicks.

Logic Pro otoh can be a click fest with Flex Time, which is why I don’t use Logic Pro much for audio editing.

If Reaper can do without the added clicks and same stretching tech why can’t Nuendo?

Yes, that would work too, the easiest workaround I found is to switch the algorithm from Elastique to Standard which often solves it.

The time it takes however, when you receive a session from a client, to locate a click that is not visible within dozens of tracks is something you wouldn’t expect from a major DAW, even if it is a third party technology, it is included with Nuendo and should be optimised not to produce disruptive artefacts.

I often get Cubase projects with tuned vocals, but my client isn’t knowing that much about the different algorithms and is using an Elastique algorithm sometimes.
I experienced no clicks so far.

Yep I get this problem constantly, it’s a source of great irritation. Doesn’t matter what buffer size you have, the click will be there in the same place every time unless you change timeline position or algorithm, as NicoSun has pointed out.

Sent this as a bug report to Steinberg years ago, had it acknowledged, but obviously it’s not on their priority list.

1 Like