Looking for a little ASIO driver advice, will explain,,,,

Ok, I’m running Windows 10 with an E-MU 1820m sound card. Yes it’s old but up until recently, for the last 15 years+ or so, it’s been fine. But what’s happening now is, when I open Cubase 10.0.40, the only audio driver available to me is: the ‘Generic Low Latency ASIO Driver’ and nothing else. Which works of course, but leaves me unable to use my outboard synths into Cubase. I have a Yamaha AN1x and a Mopho Dave Smith.

The odd thing is, if I boot-up Cubase 9.5.40 instead, the only available driver now is: the ‘E-MU ASIO Driver,’ which is the correct one that I want. And as you know, I should be given the choice of either driver in any version of Cubase. All the ASIO drivers on my system list up in Soundforge. But I’d be happy if I could get the correct ‘E-MU ASIO Driver’ in Cubase 10.

First thing I did was reinstall the drivers for the EMU 1820m, which I’ve done about 4 times now, but to no avail. So then, in a vain attempt at using logic, I thought, maybe there’s a dll, or something, that I have in Cubase 9.5 that’s somehow gone AWOL in Cubase 10? But for the life of me I can’t find anything of the sort. And trust me, I’ve spent hours searching. I’m reluctant to reinstalling both versions of Cubase because the idea that both 9.5 and 10 would develop such unusual opposing faults, at the same time, makes no sense. That pesky logic again.

So anyway, if anyone out there has solved a similar problem, or as any clue that might help, or could offer any advice at all, I would be eternally grateful for the heads up. I’m sure there are plenty of peeps out there who are infinitely smarter than me with this stuff :ugeek: - So if you have any ideas at all, don’t be afraid to pipe up. I wouldn’t be surprised if a solution had been staring me in face all along :blush:

Cheers!! :wink:

Are both Cubase 9.5 and 10.0 64 bit? Is the driver 64 bit? If the two Cubase versions run with different bits :laughing: they load the driver list from different places:

If you are comfortable with checking the Windows registry, you can find the 32 bit ASIO driver list at HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\ASIO and the 64 bit ASIO driver list at HKEY_LOCAL_MACHINE\SOFTWARE\ASIO

Have you tried “ASIO4All” driver? EMU0404 is to old to have 64-bit driver I will Guess. :confused:

What Windows 10 version are you using?
If you have 1903 or above please check the links for a solution:

https://vk.com/topic-31885720_40489303
https://www.kvraudio.com/forum/viewtopic.php?t=529349