"Loop" based MIDI out of sync

Hello guys
Hope someone can point me in the right direction with this annoyance I experiance.

Running my Cubase 7 x64 on WIN x64 w MR816x … running super smooth and stable. The only problem I have is :

When I have a midi track that has a some sort of “loop” based VSTi sound (e.g. Halion SE - 12 String Auto Strum - program that plays a strummed guitar pattern triggered by a MIDI note).
Whenever I click on “Solo” or “Mute” function on any of the tracks in the project and then revert to previous state (un-Solo, un-Mute) the above mentioned MIDI track sounds (12 string acoustic in the above example or any other similar loop sounds/tracks) go out of sync. All other audio and MIDI track stay synced except the looped/sequenced ones. (and the behaviour is the same wheter I Solo/Mute/activate plugin in the Arrange window or within the Mixer.
Those troublesomed tracks start playing normally only if I stop the cubase and start it from the beginning (1st bar) . Again - this doesn’t happen to any other “normal” midi tracks - so only to those “looped”/“sequenced” sounds.
I don’t think such behaviour is normal - so if any of you kind souls could point me into the right direction I would be very greatfull.

Thanx in advance

bojc

The tracks you are creating for the Halion SE guitar track probably have long, sustained midi notes, to create the strumming effect. When you mute the track, the midi note stops, and when you unmute, the note or chord starts abruptly wherever you are in the measure. This is causing it to sound “out of sync”. Keep in mind the flex phrases are not really loops, but more like an arpeggiator. They need to triggered on the beat to sound right.
If you need to mute and unmute there are ways to accomplish that

Philskeys, thanx for the quick response and your explanation … yeah “arpeggiator” is the more correct terminology for that. I’ve noticed that if I unmute on the beat the things stay in sync :slight_smile: , besides I can always freeze such instrument and have no further sync problems …
You are saying there are ways to “mute and unmute” . Care to elaborate that more?
Again thanx for your input and explanation

b

I am guessing you are trying to create breaks in the strumming pattern. Some ideas:
If you are playing chords on a keyboard, leave gaps and the strum stops.
Export Mixdown to an audio track (essentially the same as freezing the track)
If you use Halion Sonic 2, you can drag and drop the midi data onto a track, and turn off the flex phrase. then you can edit the midi data in the editor.

In preferences -> VST Plugins, see if you have “Suspend VST3 plug-in processing when no signals are received” turned on. If so, turn it off and see if that helps.

Philskeys and JMCecil - guys thanx for your suggestions …

I turned off “Suspend VST3 plug-in processing…” but it didn’t change a thing …

Now this thing is intrigueing me even more LOL - so I did a little test …

I created a 4 bar project with only 2 tracks …

  1. Track : Halion SE - “12 string acoustic guitar strum2” ( triggering strums with 1 whole note on bars 1 and 2 and 1 whole note beginning on bar3 and contuning to the end of bar 4) [edit]
  2. Track : Halion SE - Default GM Rock drum kit ( simple midi drum pattern)

Interestingly enough - that 12 string strumming sound stays in perfect sync ONLY when I Solo/un-Solo this particular track … if I Solo/Mute /or do whatever operation to any other track in the project (in my test case MIDI drum track or here could be instead a simple audio loop which is of course in the same tempo with project tempo) that “12 string strumming” sound goes out of sync as soon as I “return” to the initial state - meanning as soon as I unSolo/unMute the other track …
At first I thought - OK … mouse click causes this unsynced behaviour of such arrpegiated sounds, but obviously this is not the case, since as I explained earlier Soloing/unSoloing the concerned “12 string acoustic strum” track doesn’t dissrupts things … only if I do this operation to other tracks in the project …

I woul just like to understand this behaviour, cause it doen’t seem logical to me …

Can any of you who has a spare 5 minutes try that little test I explained above for me - I wonder if the results would be similar.

b

omg this is driving me NUTS as well - running into all sorts of problems with Maschine. Every timeI solo another track Maschine loses sync.

Anybody got this figured out???

This is still a problem in 2020