Loop Browser to Play Audio Files by Project Tempo

Hi, the Midi stuff from the Loop Browser aligns great to the tempo palyed in the project. For the Audio files in the Loop Browser, is there a same function ? Or do I have to put them each on a track and time-remap them by hand ?

Here it seems to be audio files that do adjust to the current tempo, but haven’t seen how this works in Cubase 6: http://www.youtube.com/watch?v=-kzmCZVKSKg

Regards,
Frank

gotit, there is a “Align Best To Project” Button at the right side of the preview window.

hm … now I see that the adjusted timing of an audio item in the Loop Browser is not taken over to the track when I drag it from the Loop Browser & drop it on a track …

how does this happen to work ?

I need the audio loop in the tempo of the project of course. I know though that timing can not over excessively be different, otherwise the quantizing-effect gets hearable …

Musical mode switched on for channel?

thx for reply. tried it but does not do the way as in the video, it still just keeps its own timing.

when I drag an audio drum loop in groove agent one, it does not adjust to the project tempo yet … how is this done ?

even if I time stretch the drum loop audio on the track and drag it on a Groove Agent One pad, it brings the old tempo … !
So I Audio Mixdowned it and r-imported the drum loop and then dragged it on the Groove Agent One pad … that worked, but is way to complicated … imagine I need to change tempo !!

How does this work ? Does someone know how to fit project tempo with audio items and also in conjunction with Groove Agent One ?

Hi Frank,

Firstly – I have noticed that Musical Mode gets switched on by default for loops dragged from Media Bay only if the loop has compatible embedded tempo information, is an Acid file, etc. It won’t happen if you drag a random untagged file with no embedded tempo metadata, regardless of which preview setting you make in Media Bay beforehand. Now it should work properly with all Steinberg-supplied loops, and if not, maybe you are in bug territory :confused:

Regarding the Groove Agent One observations. Bear with us here, it’s a deep topic. When you say you applied time stretch to the file and then dragged it into Groove Agent One, do you mean you engaged Musical Mode? I ask because the issue with Musical Mode is that it is a realtime time stretch – in other words the file on disk is not affected, instead the event’s playback rate is stretched to fit the tempo at the actual moment it is played back. You can confirm this by noticing that if you engage Musical Mode to get the loop to conform to the Project, no bounce or mixdown occurs (i.e. no processing progress bar pops up). The stretch will happen only on playback.

One of the main advantages of realtime stretch/compression is that it will conform to the project’s tempo without fussing around. So if you for example decide that after some listening, your global tempo works better at 130 than 128, you don’t have to go back and re-bounce all your loops to be x number of bars at the new tempo. The other advantage is that if you have a gradual tempo change, it will change the tempo of your loops in realtime – which is impossible by any other method than a realtime stretch.

The disadvantage is that since it is a realtime parameter, when you drag and drop that file somewhere else (such as Groove Agent One), it doesn’t respect the settings for the event in the project window and instead just plays back the file as it exists on disk. Honestly it might be helpful if this default behavior changed – but then what happens to the file on the pad in Groove Agent if you change your tempo :wink:

What I would suggest for your situation. First disengage Musical Mode for the event in question. Then use the Time Stretch tool (click and hold on the arrow tool in the toolbox, and select “Sizing Applies time Stretch”). Then drag the end of the audio file to be the length it needs to be, and it will create a bounced version that plays at the proper rate. For example if it should be a 2 bar loop, but it is currently something like 1.76434 bars in the Project window (because it is the wrong tempo), use the Time Stretch tool to lengthen it to 2 bars. You’ll then have a tempo-synced 2 bar loop that should work at that tempo when dropped into Groove Agent One.

If you do this, make sure that that the “Time Stretch Tool Algorithm” setting in the Preferences is NOT set to Realtime, or it will defeat the purpose.

Cheers!

Meta

Hey Meta, thx for taking the time to lighten the details so thoroughly ! a I’m using steinberg supplied items in media bay, they do match project tempo in the media bay when played back.

Also wished Groove Agent One would handle project tempo settings of events right away, that would become a sound workflow then. As heavy as cubase is with it’s functionality one would assume / expect that an easy timing workflow really is provided … master essential stuff for smooth post dubbing I’d say.
In case it really is a missing feature and not a usage issue I vote for steinbaerg having this upgraded. That’d be cool.

I now have the issue that I’ve hit-point sliced the audio item and although I “removed them all”, they still stay … also when I drag the item from the media bay it always has slices again. any idea how do I get rid of them entirely ?

Thx,
Frank

Hey Frank –

I can tell just by looking at that screenshot that what you have there is a so-called “Audio Part”, and not an event with hitpoints. You might be confusing hitpoints with slices – hitpoints are the transient markers that get added to the event when you press the “Edit Hitpoints” button. They define where the slicing (or warping, or markers, etc) is about to take place. Slices, however, are the resulting discrete audio chunks that are created from the hitpoints when you press the Create Slices button. After the slices have been created, they are bundled into an Audio Part, which is what you have there. If you double-click on that audio part you will see it’s a container for all the slices. Because of this, you can press the “Remove All” button all day and nothing will happen, because there are no longer any hitpoints – they were used as reference markers to create the slices, and now they’re gone. I’m not even sure how you got the “Remove All” button to show up after the file was sliced…maybe you opened the Audio Part and clicked on one of the individual slices…?

Anyway the real purpose of the “Remove All” button is if you are trying to manually arrange the hitpoints before slicing (or warping, or creating markers, etc), and after futzing around realize you should probably start over. Once it’s sliced though, you can only back out of it via the edit history (i.e. in the menu, Edit --> History, Ctl/Cmd + Z, etc).

Some of the tempo-based stuff can seem bewildering. I was actually considering starting another thread for the developers with some features requests…or in this case, feature “consolidations”…!

yes I selected an audio part that brought the hit-point tab back … autsch this is all space shuttle tech to me … I just wanted to have the tempo of the project when i create music.

in the meantime the audio-drum-loop in the media bay plays normal, but when I drag it on a track to stretch length with musical mode off (which I actually remember i did as an alternative already), then it appears as the slices container … trying to get the audio-drum-loop the way it plays in the media browser, not with the slices, so I can lengthen the thing. The slices version though is nicely keeping the timing of the wave portions of the sound, but this drum loop is not good for this approach, too many overlappings being sliced apart.

AFAIK, this will happen if the file type you are dragging from Media Bay is a REX file…i.e. in the File Type column in Media Bay it will say REX or REX2. These are files with embedded slice info. If it happens with any other type of file, then it’s a mystery! :open_mouth:

ah ok. any idea how a rex file is to be unsliced ?

I don’t think you can “unslice” a .REX file per se, but you could just bounce it once it’s in the project. Audio --> Bounce Selection. I would play it back to make sure there are no artifacts before doing this. Sometimes doing Audio --> Advanced --> Close Gaps (Crossfade) can fix any pops or other weirdness in sliced files before bouncing.

But maybe someone else knows how to drag it into the project while ignoring the REX info…I tried some modifier keys, and got a REX file to drag from Media Bay without being sliced when I held down the Ctl (I’m on the PC, I guess it would be Cmd on the Mac) – but what I got wasn’t a REX file, nor anything pretty :wink: It was just a strangely elongated file…try it on a REX file and see what I mean…