Loop region remains same timespan when bpm changed

If a loop is set for 16 bars, when the bpm changes the loop should remain at 16 bars rather than at the same timespan as it was under the previous bpm. I just encountered the behaviour where it remained the same timespan and found it counter-intuitive and unaligned with the behaviour of Cubase in past releases.

Windows 10, v10.0.15.


What do you mean by “loop”, please? Do you mean the Cubase Transport Cycle or do you mean an “audio loop”, i.e. Audio Event?

If you mean the Cubase Transport Cycle, then it should works as you expected. So if you change the tempo in the Cycle, the Left and Right locators (which define the Cycle length) should stay on the same Bar positions.

If you mean the Audio Event, enable the Musical Mode of the Audio Event to get the wanted behaviour, i.e. the tempo of the Audio Event follows Cubase tempo.

Yes, I mean the Cubase Transport Cycle.

It seems Cubase 10 can startup with some whacky, corrupted view on how things should work, such a session will encounter many odd behaviours.

It sounds like you’ve got your Loop using Linear Timebase and not Musical Timebase.

Right click on the loop and check “Bars + Beats Linear”