Losing access to Yamaha Steinberg driver

I use Cubase Elements 12. An old problem today recurred: when I started Cubase, it could not find the existing driver for my UR22 interface. I had changed nothing and my Windows PC is using the UR22 as its playback device. I downloaded and reinstalled the driver to no effect. In the Cubase Control Panel, only the ASIO driver was visible. Any suggestions?

Hi,

Wasn’t there any (hidden) system update?

I would download and install the latest Steinberg driver. Make sure, you install it as administrator, please.

I did that. I manually uninstalled the driver, went to the Steinberg site and downloaded V2.1.1, installed it, restarted my PC… and still nothing. It’s present in my program list, in my Windows Audio, in Audacity but not in Cubase. I uninstalled Cubase and reinstalled it using the Download Assistant; now it can’t find a licence.

This help site is not as helpful as it might be - there appears to be no means to set automatic notification when I receive a reply even though it is set to ‘Watching’.

Hi,

Could you also install Cubase as administrator, please?

I don’t know how to do that. There is no option when I install it using the Download Assistant.

Hi,

Right-click the installer file and select Run as Administrator, please.

OK. I have done that. I still get an error: No valid license found.

Hi,

How does it look like in Steinberg Activation Manager?

I started Cubase this morning and it ran. However, there is still no access to the Steinberg driver, which is also still available to everything else in my PC.

Hi,

Are you sure, you have installed Cubase Elements 12, not other version or edition, please?

I started Cubase this morning and it ran with no licence problem. However, there is still no access to the Steinberg driver, which is also still available to everything else in my PC.

Hi,

Can you see the driver in the Studio > Studio Setup > Audio system > ASIO driver, please?

No. Instead of the usual dialog, I see only a text box headed ‘Generic Low Latency ASIO driver’. If I uncheck the Card Options box in that, the Steinberg UR22 appears in its Input and Output ports but it still fails to be available in Cubase.

Hi,

Could you attach some screenshots, please?


Hi,

What about the Audio System > ASIO Driver list, please?

That fixed it. I’ve not used that button before. I have no idea why Cubase decided to change its driver. I did nothing. But at least I’ll know how to correct it in future. Many thanks for your help, Martin.