Lost connection to UR22mkII

Hi, I’d appreciate a bit of help! I’m running Cubase 9.0.40 with a UR22mkII (with up to date drivers and firmware) on a PC using Windows 10. This has been running fine for a couple of years, with one earlier blip - see later. Just fired up Cubase to do some work and I find that it can no longer see the UR22! Tried reinstalling the drivers and the firmware, rebooting, unplugging and re-plugging the UR22, all to no avail! There is nothing wrong with the UR22 as the PC can still see it and play normal audio through it, and I can use UVI Workstation from my Yamaha keyboard to play a recently installed Ravenscroft 275 so it is also handling MIDI correctly. Seems pretty clear that the problem lies with Cubase then, but I haven’t done anything to it since the last time I used it! And I don’t thing there have been any W10 updates. The earlier was blip was the same problem, but it did sort itself out without any radical intervention, I just can’t remember what I did! Has anyone else experienced this (and can remember how they sorted it)? Any help gratefully received! Andy

I would disconnect the AI then go into the Win 10 device manager and uninstall it. Then reconnect and let Windows reinstall it.

Regards. :sunglasses:

Hi Prock, Thanks for the suggestion - tried that but afraid it didn’t work :frowning: Any other suggestions gratefully received! Andy

Hi Prock, Just to let you know that I’m sorted thanks to an earlier post of yours - removed the Generic Low Latency ASIO driver and UR22 driver now loads ok. Quite why it suddenly started to interfere is still a mystery though. Anyway, thanks for your help. Andy