Lost Eucon

Hi all,
I just updated to 5.5.2 and lost Eucon. It worked great in 5.5.1 now it doesnt’t even show up in the controller list. I tried to reinstall the Eucon adapter but the computer said it is already installed. Any ideas?

I had this happen. Have you done a complete system shutdown/reboot since?

Just a restart. I’ll try a complete shut down, thanks!

I did a full shut down, but that didn’t fix it. I went into control panel and uninstalled the Eucon adapter and reinstalled it. Shut down and no luck. I see it load in the splash screen but no options in the device set up menu. I click the little + sign and there is no option for it. Should I roll back maybe?

I went through a few things as this confused me too including re-installing EuCon and re-installing the Steinberg adapter.

Here are some things to check:

  • Uninstall the EuCon adapter entirely and verify that it’s no longer in the Common Files/Shared folder. If you’re on 32bit Nuendo then this will be the X86 Common Files and for 64bit Nuendo the Common Files.
  • Start Nuendo 5.5 and check the device setup and EuCon shouldn’t be visible
  • Quit Nuendo (to update its preferences)
  • Re-install the EuCon adapter (either 32bit or 64bit version depending on which Nuendo version you’re running)
  • Launch Nuendo and see if it is now visible

The new Avid Eucon software is broken here. It is constantly loosing the connection between N5 and MCPro.
I had to roll back to 2.5.6

I am also having trouble with Eucon. It looses the conection to Nuendo and at least once a day causing it to crash. I think it is the Eucon software. As soon as I turn off my MC Transport Nuendo is fine.

Best wishes,


(in a PC)
I found out that many times the reason the Eucon connection breaks it is because I had a secondary network connected to the computer. If you have more than one network adapters active, disable all but the one connected to the MC.

So far here’s what I’ve done…
Uninstalled the Eucon adapter shut down, re installed Eucon adapter shut down, launch Nuendo, I can see the Eucon adapter load in the splash screen but it doesn’t show up in the device controller list like it used to.
The Eucon software works and sees the computer and works when Pro Tools is launched.
It worked perfect in Nuendo 5.5.1 but when I updated to 5.5.2 is when I lost it. I’m tempted to uninstall Nuendo and start fresh with 5.5.1 again. I would hate to lose my preferences though.
I appreciate all the help so far, any other ideas? Any one have Eucon working on 5.5.1?
P.S. I am on Windows 7

I only have the MC mix and MC Control hooked up, no other network. So is there a history of bad Eucon behavior? Maybe I should get one of the CC121 things.

Can’t you roll back to stable Eucon?.

I don’t see why I need to. Eucon worked and is working in other programs it doesn’t work in Nuendo right now so I should roll back Eucon and risk more issues with other programs?

Well, this on is on me. I forgot to install the Eucon Adapter license on my elicenser for this machine. All better now. Eucon Ho!