Lots of probs with DP2

Hi everybody,

got the following problems:

  • Dorico Pro 2 ignores my USB-Licenser. When I start DP2, the ELC window pops up and allows me to use the test version for a couple of hours. I’ve got an activation code, but the ELC manual tells me that it’s not necessary to enter the code, because it would be sufficient to put the USB-Licenser into the computer after having installed DP2. I did it this way, but the above mentioned situation doesn’t change.

  • no playback: opening the options of the GENERIC LOW LATENCY ASIO DRIVER, no audio devices are listed. I run my system with the Yamaha MG12XU that worked perfectly under D1.2.

  • as I’m allowed to have 3 instances of DP2 as an owner of the USB-Licenser, I installed DP2 on my notebook, too. That is most important for me!!

So my question is: Is the Halion Sonic SE 3 installed during the DP2 installation process or is it not?

I suppose that I have to install the sound library separately, 'cause I found an installer for both Dorico playback folders. I did run the installers twice, but every time I got the notification that some files are corrupted and that I should try a fresh version. If there’s a fresh version, please tell me - I bought DP2 last Saturday…

  • YAMAHA Audio USB driver: as I’m runnig a Yamaha Motif Rack XS in my system, I tried to install it, 'cause (again) it worked perfectly under D1.2!
    If I want to install it under DP2, a notification pops up and says, that there is something wrong with this package etc.

So my status at the moment is:
I can enter notes under DP2, but get no playback :frowning:
On my notebook I can’t do anything :open_mouth:

Maybe I’ve made some mistakes - if so, please tell me!

Would you please be so kind as to help me?



From what I’ve been reading (at times non-stop, it seems) over the past few days here, most or all of your problems are likely to be solved pretty quickly.

May I suggest a quick look at these threads, which I hope are relevant to your particular hiccups?

Good luck!

Certainly you need to enter your Dorico 2 activation code into eLCC to activate the license on your USB-eLicenser, if that is indeed where you want your permanent license to reside.

For your audio problems, I suspect you need to switch off the option for exclusive control of the ASIO device in the Generic Lower-Latency ASIO Device control panel, accessible via Edit > Device Setup.

Hi Daniel,
sorry I’m answering so late, but I was in hospital for 3 weeks. Now things are better and I’m back to business.
I tried to enter the activation code, but I can’t :slight_smile:
Please have a look at the snippets I’ve attached.
These 2 windows appear after clicking on “Enter activation code”.

Can you or anybody else help?



It’s me again…

Thanks, Daniel, for solving the audio problem on my PC!!!°

I’m sorry to hear you’ve been in the hospital, but glad you’re well again now.

Try restarting your PC and running eLCC before you run any other software, then enter the activation code into it before you run Dorico.

Hi Peter, you also need to install the HALion Symphonic Orchestra sound library, that’s what the message in DP2_2.png is all about. Strictly spoken, you can run Dorico also without that library, it does work, but playback will be sparse, so you better install it.

PC problems solved :smiley: :wink:

Let’s see what the notebook says!

Thanks a lot!!!

Hi everybody,
can’t run DP2 on my notebook. When I start D, the e-licenser window pops up. I went through the complete licenser procedure, but nothing changed. (see snippets Dorico Noteboo(k) 1)

So next time I finished the licenser procedure - DP2 started for a short moment and then tried to install the YAMAHA USB Driver - without success (see DORICO Notebook YUSB snippet)

I finished the installation and continued - the result can be seen in snippet Dorico Notebook 2.
After that I could only leave DP2 via taskmanager (VST Audio Engine and DP2 0%)

Please help!

Dorico notebook 1.PNG.jpg
Dorico Noteboo1.PNG.jpg

Here’s the YUSB png

Sorry, the system doesn’t accept the YUSB png - I try it later

Here it is…

You seem to be trying to run Dorico 1 rather than Dorico 2, though that shouldn’t really make any difference: both versions should run if you have a license for Dorico 2.

Try restarting your computer, then finding the eLicenser Control Center executable in C:\Program Files, then right-click it and choose ‘Run as Administrator’. Hopefully after running as administrator and allowing it to perform the maintenance tasks etc. it will then allow Dorico to run as normal.

Dear Daniel,

I ran through the eLCC procedure as admin - it took a couple of minutes, but then eLCC gave “green light”
Starting DP2 led to the old result…
So I deleted Dorico 1 and the YamahaSteinberg USB driver!

You can see the result via attached .png :frowning: :slight_smile:

Shall I reinstall the DP2 software?

Got no other idea!!

Here’s the other .png

Yes, please reinstall DP2 and also install again the YamahaSteinberg USB driver. Then let us know how it goes.

It seems to work fine :slight_smile:

Thanks a lot!