Loud noise after processing with gain reduction in Gain Dialog (Wavelab 11.1)

Dear Phillipe,

since Wavelab 11 I have the problem with editing in the Gain Dialog that the place I edited is replaced with a digital noise (0 dB). The error does not always occur. I can’t reproduce the error either.
Sometimes the error is only visible after I have saved the audio file. Before that it is only audible, which causes me to be terribly frightened when suddenly a digital noise with 0dB comes.
The error occurs on different computers (1x Windows 10 and 1x Windows 11). It also doesn’t matter how much dB I lower the audio at the point.

The constant startling is a bit annoying in the long run. What can I do to avoid this?

Best regards, Martin

WaveLab Pro, Elements, Cast?
Are you using the latest 11.1.20?
Are you working on audio selections or the whole file?
How frequently would you say it happens, approximately? (kind of once every…)
What are your typical audio sources on which this happens? Mono, Stereo? What sample resolution, 16, 24, float, … ?

Wavelab Pro 11.1.20 (the problem appears since 11.0)
I am working with the wole file in the audioeditor (not audiomontage)
It happens with varying frequency. Approximately 10-20 times per audio-hour
I work with Mono, 48kHz, 32-Bit float

You mean you process the whole file with the gain dialog. Right? (not just selections of it).
And the loud noise you get, is it on the whole file, or only in some parts?
Are your audio files particularly short or long?

I have tested here with sine tone 20 min and 40 min
processed with “Gain” at different settings + dB and - dB
and saved file wav mono 48 kHz.
I can’t make noise wav here!

MacBook Air M1 Monterey with WaveLab 11.1.20

regards S-EH

Ah, I misunderstood that. I only process very short parts of an audio file, approx. 100 - 1000ms (for example, for lowering breaths).
Mostly the audio files are quite long, about 30 - 180 minutes.

Here you can see an example…

Here you can see a zoom of the area. The top level is +770.491 dB (!)

Each time you apply a gain, WaveLab creates a small temporary file, one for each gain action. And when you save, a new whole file is recreated.
When the problem happens, is it immediately when applying the gain (when WaveLab creates a small temporary file), or is it later during the process of saving, when the whole file is recreated?

The problem happens immediately when applying the gain and not later when saving.

Thanks, I have gathered enough information to try to reproduce. I had a similar report in the past, but could not reproduce it. I will try again.

Thank you.
My problem so far has also been that I have not been able to reproduce it. It seemed like it was happening completely randomly.

You could try the following alternate workflow:

  • Insert the leveler plugin in the Master Section
  • Use the settings like on the picture
  • Click on the button “Render In Place” (or simply use the shortcut).
    In the Render option, there is also a crossfade option that you might find useful.
    This workflow is quick: select audio, render with the shortcut, select audio, render with the shortcut, etc.
    Internally, the mechanism is very different than the one with the render dialog. Maybe that will allow you to avoid the problem. If you try this, your feedback is welcome.

Thanks for the tip. I will try it out.
However, I can only do it this way temporarily, because I have other plugins in the master area that I use constantly for short selection areas for rendering, so I tI always have to switch between the leveler and the other plugins.
But for now it’s a solution. :+1:t2:

There is a simple and quick way to manage this: set the leveller plugin to “SOLO” and all other plugins will be ignored. Note, however, that the Master Section gain is always applied.

Actually, what I am describing now is a powerful but little known way of applying plugins effects, because it’s easy to try different plugins alternatively.

Yes, I’ve indeed been using the solo function for some time now and also permanently use shortcuts to solo the individual interfaces separately.
Because I do voice production, I am in fact also permanently dependent on quickly selecting the different plug-ins to successively lower a plop here and remove a crackle there via Mastersection.
So far it was very practical to lower the level by a fixed amount with a single shortcut via the Process menu. :slight_smile:

I have now tried the workflow via Leveler in the master section. Unfortunately, the problem appears there as well. This time the audio playback stutters first with a short noise afterwards. I also had the phenomenon with the short stutter before. I recorded this part and now you can see the stuttering well. If you play this file, the cursor and the waveform are not synchronous with that what you hear. I can send it to you if you want.

Yes, please. This case is mysterious.
Please also send me a ZIP file with your preferences as stored in \AppData\Roaming\Steinberg\WaveLab Pro 11\

Ok, here are the files to download (included my preferences from wavelab 11):


Thanks. The bad segment represents about 2.6 seconds. Does that mean you have processed this segment of 2.6 seconds, and this resulted in this corrupted audio? (and you have saved this file before sending it to me).
I understand you are not recording any audio through your audio device; you are processing audio offline, with the render option, right? (in other terms, the samples in this audio file did not go through your audio device in any way, recording or playback).
I am asking, because you say “I recorded this part” (what does that exactly mean?), and also, there is a pattern of about 512 sample blocks in this corrupted audio (where it stutters), but this value 512 is not used by WaveLab for rendering, while it is used for recording and playback. Hence this is not clear.
Are you using the External Gear plugin by chance?