Loudness issues

Hello,

I recently mainly used headphones to work with Dorico and I noticed that when I selected a note to
start playback from there, this note they can be played very loud.

I use strings most of the time.
If I select the same note a second time she got played at a “normal” level.

It’s annoying as is random (50% of the time), and heart my ears.

It’s not dependent on the nuances of the selected notes.

Also, I use the default Halion library without any changes in the parameters,
but the general volume is very low.
I need to put the of my computer near to maximum to hear Dorico correctly.
In other programs, I don’t have this issue.
(it was my mistake, as the main output in the mixer was too low)

Best regards,

Have you checked you have the correct expression maps assigned to the HALion instruments in your Endpoint? In my experience it’s the common culprit for low volume.

As for very loud note audition, I have the same issue. My settings in Preferences are set very low:



However, the very first press of a note is always CC or Velocity value of 87. The second press is most often, but not always, at the correct value of 35. I wonder if it is somehow related to the controller reset values Dorico sends when playback is stopped, but it is indeed a problem. However, I haven’t tried un-checking the “Reset Controllers” button because I do need them reset to default values.

Thank you ebrooks for your reply.

I don’t know if my HALion instruments Endpoints are correct but I didn’t set anything special,
and it happens in every project.

I tried to use a fixed volume to play selected notes set to 35 but it didn’t fix it.

It happens also after inputting a note and turning the carret mode off.

Check for it here:


A potential issue is that Dorico assigns Velocity in the “Default” expression map but many non-percussion HALion instruments actually use ModWheel (CC1 Controller). If you have an incorrect map assigned, HALion turns the dynamics controller to zero until it receives a signal to set its value to something specific and that’s how you get extremely low volume: HALion is waiting for ModWheel values and is ignoring the Velocity it’s getting.

The other option is to use the HALion playback template - that should load the correct expression maps automatically.

Preferences > Play > Audio Device Setup… > Device Control Panel… > un check “set device attenuation to 0db” (it’s this last setting that will cause Dorico to turn the volume all the way up when you open a new project. It’s useful in some circumstances / with some hardware, but probably a realllllly bad idea if you’re only using headphones.

Here is my routing.

Is this specific to the audio device? I don’t see that option - I get the device menu instead

Thank you Romanos,

My Device Control Panel set device attenuation to 0db was unchecked.

hmmm… well, it must indeed be something about your instrument setup then.

There is a gap in channel assignments but the maps seem OK. The other options I’d check would be mixer settings, the template and if anything has been modified in HALion instrument itself that results in low volume. If you post a project file, I can take a look for you although I’m on Windows.

The master output in the mixer was not set as 0.00

I saved a template with -6.02 and that’s why each project the volume was low.
Thank you. That fixes one problem. :+1:t2:

1 Like

I’m not quite sure whether you’re referring to a single note being too loud when playing back or that the dynamic is for a while too loud until a new dynamic instruction is met. Or even that the note is simply too loud when auditioning that note by clicking on it (in which case what @ebrooks says is the solution).

I find not infrequently an issue with too loud dynamics when starting playback across various libraries which seems to be caused by faulty MIDI chase – the situation is rectified at the latest when a new dynamic is encountered. And it’s not just a Dorico issue either – I certainly had it in Sibelius for instance. This issue at any rate has been aired before but I don’t think there is any known solution for it.

Thank you for your reply dko22,
but it’s not really appropriate in my case.

I have an issue getting sound too loud when selecting a note.
ebrooks doesn’t have a solution for it or it doesn’t work for me.

As mentioned above I use the default instrument (Halion)
and it’s not caused by the dynamics.
It’s really annoying when using headphones.

By default Dorico uses the dynamic of the note itself when auditioning. If you would prefer it not to do that, set Use fixed volume to play selected notes to a comfortable value on the Note Input and Editing page of Preferences.

Thank you dspreadbury for your reply.
ebrooks also suggest to use a fixed volume to play selected notes but it doesn’t fix it.
It is not related to the dynamics of the note.

When listening with headphones, I recommend to insert a limiter to the master/output channel as a protection measure. This way you can at least prevent the volume to exceed a desired level.

I just tested it again to double-check and indeed I am also not getting reliable auditioning volume regardless of the settings I make in Preferences, as mentioned earlier in the thread. (To clarify, there was a separate issue in the OP related to overall loudness, which was resolved via mixer adjustment, or so it seems).

In my case, Dorico first resets all VST instruments at file open to dynamic value of 48 (corresponding more or less to mf in my Expression Maps). Then, when I click an empty staff to audition the instrument itself, Dorico resets the dynamics just for that instrument to value 87 (f in my maps). Re-applying the template is identical to re-opening the file - the behavior is consistent.

Auditioning selected notes in Write Mode produces the same behavior on the first selection or mouse click - Dorico initially sets that note dynamics to 87 regardless of the dynamic marking used in the score - and it is always only on the second click of the same note that the levels I set in the Preferences (value 35) are obtained.

This happens in all files and in all VST instruments (they are housed in Cubase so I can see in real-time how Dorico resets controllers as I open a file or select instruments and/or notes).

The log file usually shows the following sequence (so naturally I suspect MIDI Monitor is the culprit):

2022-09-05 09:05:05.187 [info] Posting command (requested): Edit.SelectAtPoint X=3250, Y=1678, AddToSelection=0, BlockSelection=0, NextSelectionAtPoint=0, SelectionTriggerAction=0, Post=true
2022-09-05 09:05:05.187 [info] Executing command: Edit.SelectAtPoint?X=3250&Y=1678&AddToSelection=0&BlockSelection=0&NextSelectionAtPoint=0&SelectionTriggerAction=0
2022-09-05 09:05:05.276 [info] addEventsForAudition() adding 1 events to buffer #:0
2022-09-05 09:05:05.280 [info] addEventsForAudition() adding 1 events to buffer #:1
2022-09-05 09:05:05.280 [info] addEventsForAudition() adding 2 events to buffer #:2
2022-09-05 09:05:05.291 [info] processAuditionEvents() - processed 4 events
2022-09-05 09:05:05.348 [info] addEventsForAudition() adding 1 events to buffer #:0
2022-09-05 09:05:05.355 [info] processAuditionEvents() - processed 1 events
2022-09-05 09:05:05.390 [info] notifyPostCommandExecute: Edit.SelectAtPoint?X=3250&Y=1678&AddToSelection=0&BlockSelection=0&NextSelectionAtPoint=0&SelectionTriggerAction=0 (204 ms)
2022-09-05 09:05:05.392 [info] Process SetMIDIMonitorDestination
2022-09-05 09:05:05.474 [info] Process SetMIDIMonitorDestination
2022-09-05 09:05:05.524 [info] Process SetMIDIMonitorDestination
2022-09-05 09:05:05.524 [info] notifyMessageFinished() - request queue empty


And finally, in 99% of cases the very first time I select a note or staff to audition after opening a file Dorico instead plays back the topmost staff and it plays it back at value 87.

I used to think this had something to do with my particular template, routing and modifications of the Expression Map but the OP reports something similar using factory template and stock instruments, so perhaps it’s not just me.

EDIT:

Scrolling up and down the log, I also noticed this (not sure if it’s relevant):
2022-09-05 08:54:20.919 [info] Document setup and activation complete but sync messages still in the queue

That is the expected behaviour. When you change the endpoint used for auditioning (e.g. by selecting a different instrument), Dorico sends a set of MIDI messages to ensure that the endpoint is set up appropriately to be able to make a sound (e.g. if the sound requires the use of a MIDI CC to specify dynamics etc.).

Thank you for your very detailed answer.

I’m not sure to understand it all, but it seems that Dorico reset to a value of 48 mf
when selecting a note for the first time after playback.

My problem might be caused by the fact that the main output of the mixer wat as -6db
and I had to put the volume of the headphone output to nearly the maximum.
Then when I selected a note for the first time I got mf of f hurting my ears.

Now with the main output to 0, I still fell the volume gap from first selecting a note for the first time and the second time but it doesn’t hurt.

I just upload a small project with the main output at -6db just to illustrate
what I was experiencing.

https://dropover.cloud/48f8a7

I think it solved