LP automation is late.. why ?


i have a region where i want a low HC filter pre.
i use the Fill Loop, put markers around the region enter loop and play to record my automation at the right Freq.
i press stop, and play the sound starting before the region.
i can clearly hear that +/- 10ms of the begining of the region is played without the HC :imp:
i zoom to check automation start and it’s perfectly on the region. it starts to go down few ms before the region, reach my freq at region start but the sound is not correct.

i had this for long time and never looked into it. what is going on exactly ?

I don’t have time to check in depth, but I too see a discrepancy between the loop range that we punch to and the actual point that the filter is applied. In my version it also appears at the end.

I created a range, sent white noise to a group, punched low-cut on that group to that range, and it will cut before the automation line shows the filter being engaged, and it will disengage before it is supposed to at the end.

Seems to me like there is either a programming flaw that is a constant or else there is an oversight in compensating for a user created variable. Try changing variables, one at a time, while repeating your test.

  1. Change audio buffer sze.
  2. Add a mastering type plugin to a different channel that requires large latency compensation.
  3. Change Record Latency Compensation in VST settings
  4. Change Automation Thinning setting

Vary any other parameter you can think of relating to this issue, one at a time. My bet is that this parameter is subject to another setting that was not fully considered by SB during programming.

I’m not saying these tests will fix it just that an end-user identifying the problem specifically and posting it is likely to result in a fix sooner than later. I use very little automation having other means I prefer to use. MattiasNYC is a smart guy. He will probably figure it out.

Yes, I know it should not be our job but in the real world sometimes this is what works. I’ve been finding problems like these since 1988 with C-Lab Creator on an Atari St :slight_smile:

Automation is unfortunately not sample accurate and can depend on your audio buffer size. There is however an option in the mixer to change EQ/Filter transitions from soft to quick. Try that.

Last post is correct its bufferdependant and can always vary a bit depending on buffer size when played in real time.

BUT perhaps the filters are also affected by the on purpose introduced slow response of the eq? I do not know but that is my gut response when reading this post.

This slow eq response has been a problem for quite some time now. As far as I can remember it was introduced because many music users wanted to be able to use ans switch eq presets. When you did that there were unwanted results in the sound, so they slowed the response of the eq. I think this happened around N5.5 - N6,0 or so. To me the response If the eq has been a problem since then.

Is this the same? Not at all sure, check if it is affected by the eq response setting?

Hi,yes quick setting solved my problem thx :wink: