Lyrics alignments & Long sentence-lyrics under one note

I really like how Dorico manage automatically the horizontal position of lyrics.
However if you have multiple words under one note, the reading become a bit confusing, unless you left-align the text.

Could we have an option so when Dorico detect a long sentence for one note (multiple words or after n chars), it will automatically align the text on left?

In sacred music, we often have long sentences under one note (usually under a double whole notes).
And I notice that I spend a lot of time to readjust them each time manually.
Furthermore, the text-align setting is dropped every time you change the lyric.

Programming Dorico to do this might create more problems than it solves. On the other hand, one thing that would really help in situations like these is if were possible to program key commands for left-align, right-align and center lyrics. I’ve often wanted this and it certainly would save a lot of time if we didn’t have to resort to the properties panel.

Ah, Vaughan, but you can :wink:

The things you need to add to the keycommands JSON are

Do I need to talk through editing the keycommands JSON again?

Excellent, thanks, and I plan to add these! But the request still remains for these settings to be properly exposed in a key Commands.

Leo, I read your thread once again about editing the keycommands JSON, as well as Daniel’s response, although that thread had to do with accessing microtonal accidentals. I’m assuming that I’m to edit the keycommands file in users/library/application support/steinberg/Dorico 3 and not the one within the Dorico application, although I’m not sure why there need to be two such files. Is there any reason I can’t use the text editor provided by the Mac system if I make sure it opens and saves the text of the file unformatted? I could buy BBEdit for $50 but I really never need what such program has to offer, except for this one instance, and I’m still looking forward to Dorico’s implementing a key command editor which accesses non-menu functions like the ones in the properties panel.

Yes, you’re to edit the keycommands file in users/library/application support/steinberg/Dorico 3, not the one within the Dorico application. The one within the application is where the program factory defaults are stored. When Dorico is updated, this file is automatically overwritten (for instance, Dorico 3 brought with it Alt+C for Add Comment and Alt+R for Reply to Comment). The file in the Users directory is a) specific to you (which matters if multiple people using the same computer) and b) won’t be overwritten by Dorico updates.

Rather than using TextEdit, download the Free version of BBEdit. It’s free and it contains more features than the previous free version, TextWrangler, which I’m still using here.

Emagnier, I deal with the same problem all the time as I frequently set psalms. It would be nice if there was a global option that stipulated either “If lyric exceeds x-number of (characters or words) left align lyric”

Leo, I’m getting strange results. I added the above texts to the keycommands file at the very top under kGlobal and the JSON file checked out to be valid but the only key command which actually works is left aligning a lyric syllable and it only functions in Write Mode. In Engrave Mode it edits the lyric offset, moving it to the left by ⅛ space at each keypress. The right and centre aligning shortcuts do nothing. Any idea what’s going on?

What key combinations did you assign to them?

I realize alignment can be changed in W and E mode, but have you tried assigning the key command in the JSON to one of those modes specifically?

I set Alt+L, Alt+R and Alt+C respectively as key commands. As I wrote, I entered them under kGlobal which should make them available in all modes, or am I mistaken? I’ve seen the kEngraveMode and kWriteMode contexts. Is this where the commands should be housed? Is it advisable to enter the same lines in both contexts to have them available in both modes?

I tried removing the three commands from kGlobal and entering them twice, in kWriteMode and in kEngraveMode. I’ll have to change Alt+C, as that in invokes the Comment window. Unfortunately, the other commands work strangely or not at all. Alt+L does nothing in Write mode. In Engrave mode it still applies -⅛ space to the lyric syllable offset. Alt+R does nothing in Write mode but it does work in Engrave mode. Strangely, if I then select Lyric Text Alignment in the Properties Panel in Write mode, it sets the lyric to left-align, meaning that the alignment is conflicting in the two modes. Curiouser and curiouser…

Well, I entered different key combinations in kGlobal (using Meta, or Mac’s Ctrl) and now the commands finally work in both Write and Engrave modes. Whew. Thanks to Leo and Dan for the pointers.

@Emagnier and Romanos, inserting the lines of text in Leo’s post above into your JSON file and assigning key combinations to them makes it very quick and easy to left align lyrics (in psalms) and it’s perhaps more fail-safe than trying to get Dorico to do it automatically.

Apologies for digging out this rather incidental point, but for everybody else reading this thread: Don’t spend that kind of money on a text editor if all you need is syntax highlighting for JSON. Like with BBedit, there’s often a free version, and there are plenty of open source alternatives that are perfectly capable to do the job.

I use TeXShop which is free and is an amazing tool to write in LaTeX, and that does serve me well to tweak the JSON files for Dorico.

You have to check that these keys aren’t already in use, Vaughan. I did actually say

in this very thread!

Of course, Leo, and I later realised I’d forgotten that, although I still have no idea why Alt+L did what it did.

And thanks for pointing out the free version of BBEdit; it hadn’t been obvious to me when I visited the website.

In Engrave mode, by default, Alt+L does this:

Ah yes, just found it: I should have checked the JSON file in the Dorico application package.