Lyrics mash

Text goes together. How can this be normal
image

Welcome to the forum @AALO_VEEVO – it’s possible that the lyrics are overlapping here because more music has been forced into this system can fit.

You could try going to Engraving Options > Lyrics (assuming you have Dorico Pro) and reducing some of the minimum gaps to produce more wiggle room: such as the minimum gaps between lyrics and hyphens, and between adjacent lyrics. This will reduce some of the horizontal spacing pressure.

Is this checked:

Screenshot

Layout Options > Note Spacing?

I would also try double-clicking on the first syllable and then use the spacebar and hyphens to hop through the first few words. Sometimes that will clear things up.

Hi
Thank you
It is marked as you said :
image

Yes, I got it if I put spaces in front of the syllable, but I have the same thing in many places and it is extremely inconvenient to do it. I used to work with dorico3 and it worked very well there. For some reason, dorico4 doesn’t want to understand that syllables and words must have spaces.
I tried to reduce the number of bars in one system, but that didn’t work either. I made the fonts smaller and adjusted the gap sizes, but they didn’t help either.
I also put the factory settings, but still the same

Well, this is certainly not normal behavior. If you want a reliable diagnosis, you can post the file here, taking out the parts that aren’t relevant if you wish.

1 Like

dreamland2.dorico (1.5 MB)
Thank you
There is working file, maybe you can see what i did wrong or why it is as it is

It’s because of the tempo changes. I deleted the signposts and it’s fixed.

I remember this happening to me before. Sure seems odd… signposts shouldn’t affect the spacing.

1 Like

Thank you
next time i know when i do something stupid again :slight_smile:

Good spot @dan_kreider ! I had just reached the same conclusion.
This looks like the sort of cascade of tempo changes that used to happen in Sibelius trying to mimic a rall/rit.

@AALO_VEEVO Is this file an import?

To retain the same effect you can use the tempo track, if you don’t want to use explicit gradual tempo marks.

Oh, it wasn’t stupid. I think this is a Dorico issue. Signposts (invisible) should not affect note spacing!

2 Likes

Basically im using cubase and it was just transported via midi to dorico and yep, there was different tempo changes.
I like to make music in cubase and if need notation, then dorico is better than cubase score editor … if dorico have one day same options as in cubase lower zone, where you can see all or selected tracks together in key editor, it will be great. At the moment dorico key editor is far from cubase , and not so handy to use. Hopefully it will soon be similar or better as in cubase :slight_smile:

Yes, indeed, there’s a problem here that needs to be addressed. For the time being, you can avoid the issue by ensuring that tempo changes (even hidden ones that show signposts) only occur at positions coincident with notes, rather than in between them.

The boring technical reason for this problem is that Dorico can currently only move items apart horizontally to resolve collisions if they are in adjacent spacing columns. Spacing columns exist at every rhythmic position where an item begins on each staff, in aggregate. So, for example, if you have two instruments of a single staff each, and you have four 16th notes on the first staff and two 8th notes on the second staff that sound together, there are four spacing columns that apply to both staves – even on the second staff where the two 8th notes sound only with the first and third 16th notes on the other staff. A tempo mark, even a hidden one, itself creates a new spacing column, and so that can interfere with the collision avoidance behaviour for lyrics (and everything else that is considered when spacing horizontally).

In the fullness of time, what is needed is the ability for Dorico to consider non-adjacent spacing columns when resolving collisions, but this isn’t entirely straightforward to achieve and so has not yet risen to the top of our list of priorities.

6 Likes

Thank you for your answer

I am getting all sorts of overlaps of words and syllables in this file (cf. impres-sions). No signposts are hidden. I have tried increasing the spacing, and the words shift. I have unsuccessfully tried shifting through the syllables (or using hyphens), which sometimes repositions the spacing.

I have tried Reset Positions and Reset Appearances, to no avail.

Other layouts (like the Pno/Vocal do not seem to exhibit this problem). I recall that this was originally a Finale file imported as XML.

I would appreciate any thoughts how to solve the problem.

geisenheimerScore240207 - Conductor - 6. -A Young Girl in New York- - Conductor - 6. -A Young Girl in New York- 1.dorico (2.2 MB)

Hi @Derrek , I found that changing this one layout option solves the words/syllabes spacing…

2 Likes

@Christian_R ,

Thank you. This has been a puzzle, but it did work, with some reservations.

Ironically Use Actual Widths had been the original setting, and I had changed it to see if it would improve the crushed spacing. When I saw your suggestion, I found the first example I could fine (in what is actually a 120-page theater score) and tried your suggestion successfully. When I went to the example page, I had to try several times back and forth. Finally, choosing the exact measure with the problem and choosing back and forth, Applying each time, I managed to get the desired resule.

I wonder if one has to apply these changes individually to each flow. I expect I will find out.

I would give you a Solutions checkmark, but since I am not the OP of this thread, you should consider you earned it virtually.

Thanks again.

1 Like

Thank you @Derrek , and glad it helped :slight_smile:
I understand your reservation. What I can add is that as described in the explanation box, below that specific layout option, it seems that the ideal widths are intended to be used when you have (also) over-full music. In your example the percentages are all green… But globally, in a large work, I don’t know what is the best option… (just thinking loud).

1 Like