Lyrics over barlines

Hello. I’ve been entering lyrics in Dorico with mostly great results. But strangely enough, in one bar a word is pushed over a barline (see attachment). Strange because there’s more than enough room for the word on the right side of the bar. I’ve tried pushing it various ways, and of course adding a space at the beginning only puts you to the next note. Otherwise, the parts look very professional, but this misplaced lyric spoils the effect. Any way to correct it?
Screen Shot 2016-12-07 at 12.33.05.png

This behaviour is very strange, since there are options in Engrave options (cmd-shift-e) to avoid bars (bars category). Anyway, in the properties, you can also change the position of the syllable (left, center or right), there should be an option working for you.

Thanks, but I couldn’t find an option for “avoid barlines” in the engraving options menu. And if by “properties” you mean the right-click menu on the lyric, the only position option I found there was above or below the staff.

Dorico doesn’t really cater for the situation where you choose to show barlines drawn continuously between the staves: normally (and indeed by default in Dorico), barlines are broken between vocal staves so that you don’t run the risk of lyrics colliding with barlines.

If you’re open to it, I would suggest you change the option ‘Barlines on vocal staves’ to ‘Break barlines between staves’ on the Barlines page of Engraving Options. If you already have that option set that way, then your instruments are not proper vocal instruments, and you should use the Change Instrument feature in Setup mode (expand each player’s card and click the little chevron > next to the name of the instrument held by the player to find this menu) to exchange your instruments for actual voices.

If you’re committed to drawing the barlines between the staves like this, then I suggest you select the lyrics that are colliding with the barline, and open the Properties panel, which is the panel at the bottom of the screen, and set the ‘Alignment’ to ‘Right’ for these lyrics.

For this reason, I would also avoid barlines between staves in vocal music (and most other, as well) but barring this, couldn’t you just nudge those few syllables to the right?

Is there an ‘erase background’ setting that could be applied to lyrics text? (I’m thinking in Sibelius terms here, of course.)

No, at present there is no means of whiting out the background behind a lyric. It can be done (somewhat unsatisfactorily, really) with a text frame (because you can set the background colour of the text frame to be opaque white). This will be added in future, of course.

I’ve tried several differnet means of nudging, but nothing worked. I think I’ll go with the no bar-lines between staves option, that makes the most sense, thanks.

Daniel, please excuse my denseness, but I still haven’t found a properties panel at the bottom of the screen. Maybe a screen shot of where it should be?

Choose Window > Bottom Panel or type Ctrl+8 (Command-8 on Mac) to show and hide it. It’s only there in Write and Engrave modes.

Got it thanks. Dorico is getting better by the day :slight_smile: .

I always prefer the uncluttered look of barlines only within the staves, especially with things like lyrics and hairpins colliding with them if the barlines extend between the staves.
Having said that, you still should be able to nudge lyric syllables in Dorico. You have to do it in Engrave mode and either by dragging them with the mouse (fortunately Dorico restricts the motion to horizontal), or by using the arrow keys while holding Alt (on the Mac).

How do I move a barline so that a lyric inside a bar fits?
(Using new Dorico Pro 2)


screenshot_2917.png

I would go to Engrave Mode, switch on Note Spacing and move the handle that’s attached to the barline.