M-Audio Oxygen 49 Direct link with Cubase 7 Help

Does anyone know how to get a M-Audio Oxygen 49 connected to Cubase 7? I would like to be able to control Cubase’s transport panel from the Oxygen 49 if possible. If anyone knows how to get the two connected it will be well appreciated if you could let me know how.

Hi mate. I don’t have an M-Audio device but it should be pretty straight forward. You install the Direct Link software/drivers.

Open C7 Devices. Open Device Setup. Click on the + sign in the top left and you should see the Oxygen in the list of devices. Add it from there, and you should be good to go.

Hope this helps.

I am assuming M-audio has developed drivers for C7. You may have to check the M-audio website… :wink:

Hi, Thanks for your help, for some reason the Oxygen isn’t appearing in the Device Setup, I installed the latest drivers from M-Audio’s site but still no luck, I just sent their tech support a support form stating the issue so hopefully they can get it connected.

Good luck with that mate. In the mean time you could set the Ox 49 as a Generic remote device, just means you will have to manually add the commands.

Are you familiar with the Generic Remote feature?

Somewhat, I’ve never really used it though.

Is the OX 49 definitely sending midi to Cubase?


I’m trying to help here, so forgive me if I patronise a little, but it helps to get all the facts straight from the off.

If you want me to help you set it up with the Generic remote I am happy to do so. Let me know.


Your good, I know you are trying to help and yeah I would appreciate your help.

OK mate.

Is it just the Transport controls you are after?

The transport control is definitely the main one I would like to have set up, but if you know how to set up more I am interested in learning how to set those up as well. Thanks

OK. If we start with the Transport then you should get the idea pretty quickly and before you know it you will be mapping all over the place.

  1. Open device setup

On the left hand side you should see a list of devices, and a folder called Remote devices. Under this should be Generic Remote. If it’s not there click on the + and add it from the list.

Ok, got that part taken care of.

So now on the right you should have a whole list of commands, Fader 1, Fader 2 etc. A top section and a Lower section.

At the very top you have a Midi Input and Out section you need to select the Oxygen for both.

I find the easiest way is to start a clean template, so start off by deleting all the entries in the top section and the lower section will delete automatically.

Highlight the command and hit the delete button on the right hand side until they have all gone.

Cool, working on that now.

How you getting on?


Have you deleted them all ?


Now click on Add.

Double click on the control name and rename it Start.

Now select (tick) the learn box and press the Play button on the OX 49 you should see the midi data update. Uncheck the learn box.

Then in the right hand column Flags. You need to enable R for Receive.

Now go to the Lower section and select the entry.

Click on the second column (Device) and select Transport.

Then click on the Value Action column and select start.

Now hit Apply. and then OK, now try the button Cubase should now start.