M1 Macmini display not sleeping when Dorico is running

Sorry to start a new thread here, when there are old ones with the similar topics, but the old ones seem, well, old (or about laptops).

Here’s the problem: I find that Dorico prevents the display on my shiny new M1 mac from going to sleep. I’m sure it didn’t do that on my older Intel Macmini - or maybe it did, and I just didn’t notice.

Old threads say that this used to be a problem in earlier versions: Dorico would not release the audio driver (like Cubase won’t either). There are various replies over time from the development team about hoping to make it optional for Dorico users not to release the audio driver .

@dspreadbury said:

Obviously I can’t close the lid on a Macmini. I can probably work round the issue with a Keyboard Maestro macro to select ‘Sleep’ from the File Menu after 15 minutes of inactivity, which will turn off the display.

However, I wanted to be sure I wasn’t missing some setting, and that this is the expected behaviour.

NB On Big Sur (11.5.2) there is no separate option in Energy Saver System Pref to put the computer to sleep after X minutes of inactivity, only the display.

Many thanks in advance,

It is indeed the expected behaviour. Your Mac won’t fall sleep while Dorico is running, but you can command it to sleep if you want to.

@dspreadbury : many thanks for the immediate response. Do you ever sleep yourself? :sleeping:

Fergus

Your intel wasn’t going to sleep either.

I’ve just upgraded from one to the other and the behavior is the same on both.

I have set the top right corner to Sleep the display. (System Prefs > Mission Control > Hot Corners.)
So, when I go to bed, I just flick the mouse pointer up to the corner, and the screen goes to sleep.

Thanks @Romanos401 - I was never very observant.

And to @benwiggy: many thanks for the tip. Much appreciated.

2021-09-03-0002

Also, on a Mac, hit Command Option and Power button all at once.
Sleeps immediately.