[Mac] C7.5.30 and OS 10.10.0. 'Sup wi dat'?

Aloha guys,

In recent weeks I have read various posts about a few Mac Cubase users
enrolled in the Apple public beta programme who were trying out OS 10.10 and C7.7.30.
(BTW most of the posts trended positive).

Not sure if there is/was a NDA (non disclosure agreement) involved but now that the OS has been officially released,
wondering if any users can ‘speak out’ and enlighten the rest of us on upside/downside issues.

I for one look for improvements/enhancements in ‘Core Audio’ or ‘Core MIDI’
parts of the OS but have found none in OS 10.10.0

Any info would be wonderful. (I have read Steiny’s official statement on installation)

TIA (thanks in advance) and Mahalo.
{’-’}

Been using Yosemite and *cubase 7.52 for about 2 months and it actually works better then mavericks. That said, cubase 7.53 wasn’t as stellar (which it seems alot of the issues aren’t because of the OS since mavericks folks seem to have the same problems)

Cubase 7.52 super solid and runs efficient. I hope Stieny gets out 7.54 for us soon.

Best,

After spending an entire day putting Yosemite through its paces - testing ALL my software, plug-ins, etc. I’m happy to say…

Yosemite passes with flying colors for me! And I’m super OCD about my systems. The transition was seamless, and all my DAWs, sessions, and plug-ins run as good or better than Mavericks.

That being said, I made sure ALL my software and plugs were updated to the latest version prior to performing the Yosemite upgrade.

Here’s a few details if it helps anyone which appear to be working perfectly:

Drivers:

  • Syncrosoft & iLok drivers
  • UA’s Apollo driver software (latest version 7.10.x) works flawlessly

DAWs:

  • Cubase 7.5.30 64-bit (have it pre-installed on Mavericks before the Yosemite upgrade. Otherwise you will need Steinberg’s Yosemite install tool - but some users are reporting issues even with the tool.)
  • Pro Tools 11.2.1 64-bit
  • Reaper
  • Adobe Audition CC 2014

Plug-Ins

  • Kontakt 4.5.1 64-bit (and I assume most, if not, all other Native Instruments plug-ins, though I read on other forums that Maschine and Guitar Rig are having problems)
  • Play 4.2.2
  • Spectrasonics (Omnisphere, Stylus RMX) 64-bit
  • Pianoteq 5.1.0 64-bit
  • WaveArts plugs
  • Waves - the plug-ins run, however be aware some forums report the WLC app currently has a bug that prevents you from authorizing new purchases or transferring licenses to/from the Waves cloud

I ran into tricky in my travels:

  • Avid’s legacy hardware drivers are touchy. I tried an MBox 2 mini and it was not recognized by the system right away. I’ve posted instructions for getting it to work on Avid’s DUC over here.

Tanx sooooo much guys for the info and tips.
{’-’}

I did a clean install of Yosemite and then Cubase 7.5.3. When I run the programme from the Application folder I managed to get the 64 bit version. But when I run cubase from the Launchpad or the dock icon it always runs in 32 bit. Has anyone noticed this. Thanks
Deminda

I can confirm this effect also for Cubase Elements 7 V7.0.80 on Yosemite 10.10.2. Has anybody a solution for this? Thanks